Support » Plugin: Max Mega Menu » Possible Bug – No JS – Hover 3rd Level Menu

  • Resolved Tracy

    (@ridgey28)


    Hi

    I have been testing identical WP websites, based on bootstrap 3.3.7, on a testing server and a non-published web version on Chrome for Mac. On testing the site with no JS the 3rd Level menu in the web version only displays the 3rd level menu on hover whilst the testing server displays as normal.

    After a little debugging I found that the web version was using the opacity set in line 97

    #mega-menu-wrap-header-menu #mega-menu-header-menu[data-effect="fade"] li.mega-menu-item > ul.mega-sub-menu {
      opacity: 0;
      transition-duration: 600ms;
      transition-timing-function: ease-in;
      transition-property: opacity;
    }

    and the working dev version was using the opacity set in line 93

    #mega-menu-wrap-header-menu #mega-menu-header-menu li.mega-menu-item > ul.mega-sub-menu {
        display: block;
        visibility: hidden;
        opacity: 1;
    }

    A a temporary fix I added the following to my stylesheet

    .mega-no-js li ul li ul{
    
       opacity: 1 !important;
    
    }

    I’m not overly worried but just wondered if anyone else has encountered this issue with JS enabled or not. Fab plugin BTW, worthy of 5 stars!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author megamenu

    (@megamenu)

    Hi Ridgey,

    Thanks for reporting this.

    I’m having trouble reproducing what you’re describing – it seems to work OK with JS disabled. Please can you list the exact steps I need to perform to reproduce the problem here?

    Regards,
    Tom

    I’ve disabled the temporary fix and tested it on Chrome, IE11 & Edge for Windows and it’s still the same. Can you email me (tracy@worldoweb.co.uk) and I’ll send you the link for the website? it’s not quite ready for the general public as yet.

    Plugin Author megamenu

    (@megamenu)

    Hi, just updating this thread.

    This has been fixed in the development version and will be included in the next update.

    http://plugins.trac.wordpress.org/changeset/1496207

    Regards,
    Tom

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Possible Bug – No JS – Hover 3rd Level Menu’ is closed to new replies.