Support » Plugin: IP Geo Block » Possible bug: disabling/enabling adds “,US” to whitelist country code

  • Resolved FireMyst

    (@firemyst)


    Hi there:

    I wanted to report a possible bug.

    I am outside the USA, but my domain is hosted in the USA. I have WhiteList Country code set to “AU” because nobody in the USA should need to access my admin site.

    Whenever I disable the IP GeoBlock plugin, and then re-enable it, the WhiteList Country code is set to “AU,US”.

    Why does it do this? Is this a bug?

    Again, I can reproduce the behavior any time by:
    * set whitelist country code to “AU”
    * save settings
    * go to “Plug ins” and deactivate IP Geo Block
    * Reenable IP Geo Block
    * view IP Geo Block settings and it’s now set back to “AU,US”.

    I’m running IP Geo block Version 3.0.13 and WordPress 4.9.8.

    Thank you.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi @firemyst,

    Thank you for your detailed reporting. But that’s not the bug. It’s specification for this plugin.

    WordPress has cron system that enables checking for updates, publishing scheduled post and so on.

    This is done by “self requesting”. So if your server is placed in US but blocks access from US, the cron system fails to work. Thus, if the cron system in WP detects “self blocking”, this plugin automatically add the server’s country code into the whitelist.

    And there are many plugins that do the same “self requesting”.

    For now to avoid this mechanism, please add your server’s IP addresses or AS number of your hosting provider into “Whitelist of extra IP addresses prior to country code” in “Validation rule settings” section. Then “US” will not be added in your case.

    I’ll provide more smart way to avoid this issue, but for now I hope your kind understanding.

    Thanks.

    FireMyst

    (@firemyst)

    Thank you for the response.

    This doesn’t appear to work. I spoke to my hosting provider, and the A record for the server one of my subdomains is hosted on is 216.zzz.xxx.yyy (masked so not publicly shown here).

    I added 216.zzz.xxx.yyy into the “Whitelist of extra IP addresses prior to country code ” configuration box and saved the changes.

    I left IP Geo Block settings and then came back to confirm it had been saved in the list of IP address.

    It was.

    So I then disabled and re-enabled the plugin.

    The whitelist Country Code went from “AU” -> “AU,US” again.

    So either I’m doing something wrong, or it’s not working as expected.

    ???

    FireMyst

    (@firemyst)

    As a reminder, the subdomain is hosted with an American hosting provider and according to https://www.iplocation.net/, the ip-address of the server is located in Clifton Park, New York.

    So since the ip-address is in the white list, IP Geo Block shouldn’t be adding “,US” to the Whitelist Country Code should it?

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi @firemyst,

    I have to say greatly thank you for your accurate reports about this issue.

    … or itโ€™s not working as expected.

    It does not work as I intended when you did the following:

    So I then disabled and re-enabled the plugin.

    When you did this, white list of IP address were never used. I’ll fix this issue on next release (may be 3.0.14). So until then, please:

    1. Confirm your server’s IP address (216.zzz.xxx.yyy) is in “Whitelist of extra IP addresses prior to country code“.
    2. Remove US from “Whitelist of country code
    3. Save changes.
    4. Please never do deactivate and activate again!

    Again, I’d deeply appreciate your cooperation!
    Thanks so much!!

    FireMyst

    (@firemyst)

    Ok. Thank you. I will mark this topic as resolved trusting you’ll have the fix in the next update. Feel free to contact me if you need a tester for this. ๐Ÿ™‚

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Thanks @firemyst!

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi @firemyst,

    I’m sorry to have kept you waiting. I released the new version 3.0.14 which fixed this issue.

    So I hope you to try one, and please feel free to let me know if you still have any issues.

    I appreciate your reporting this issue.

    Thanks!

    I can confirm it’s now fixed – working as expected on the 3 sites where I had the issue.

    Great work and thank you!

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi @firemyst,

    My pleasure, and thank you for your feedback!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Possible bug: disabling/enabling adds “,US” to whitelist country code’ is closed to new replies.