WordPress.org

Forums

possible 2.0 bug: draft post w. no title gets post ID slug (3 posts)

  1. richards1052
    Member
    Posted 10 years ago #

    A few days ago I noticed that one post I created received a numerical post ID as its slug even though my permalink strucuture called for date/post name format.

    Today, I noticed that when I created a test post, saved it in draft mode and did not create a title, WP created another numerical post slug. The post was not yet published.

    In 1.5.3 the behavior was to only create a post slug when the post is saved in Publish mode (I believe that's how it worked). Can anyone tell me why this might be happeneing?

  2. citeewurkor
    Member
    Posted 10 years ago #

    post names are based off of the title in that permalink structure. If you want to change it from the numerical value, put in a title and put in a name in the post slug.

  3. richards1052
    Member
    Posted 10 years ago #

    Yes, I understand. But why should I have to manually change the slug? It's tedious & time-consuming. And why if in previous versions no slug was created till the post was published--would a slug be created in 2.0 after saving in Draft mode?

    I sometimes write the text of a post w/o adding a title & save my text in Draft. Then after completing the post I'll add a title & publish it.

    I think it's a bad deal to generate a slug in Draft mode as v 2.0 seems to do.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags