WordPress.org

Support

Support » Themes and Templates » [Resolved] Position Issue

[Resolved] Position Issue

Viewing 8 replies - 1 through 8 (of 8 total)
  • your “navi” is set to “position:absolute;”

    Absolute positioning takes items out of the document flow. Nothing is related to it, so the outer container won’t push past it.

    You can *try* setting your #container as “position:relative;” but it may not solve your problem.

    you are correct, it didn’t solve it.

    Then you need to remove the “position:absolute;” from your “navi” section. But in looking at how things are set up, this is going to cause your sidebar to move somewhere else.

    Change this section:

    #info, #update, #news, #request {
    width: 459px;
    margin-left: 201px;...

    remove the “margin-left” and put in “float:right;”, and remove the absolute positioning from #navi, and put in “float:left;”

    Then you’ll have to clear your floats. So you’ll need to add in:

    #news:after, #navi:after {
    content:".";
    display:block;
    clear:both;
    visibility:hidden;
    }

    That probably won’t completely fix it, but it’ll give you something to start with.

    by the way, you have “Winamp” spelled wrong. 🙂

    that too didn’t work, took the background (#container) away and threw the sidebar (left side) down about 30 pixels. I appreciate the help alot though.

    Actually, yeah, it worked, but yes, it does push the stuff down a bit below the header. What I gave you was a *start* not a complete solution.

    Depending on what browser you’re viewing in is why the “container was taken away” – it’s not “taken away” it just that whatever browser you are using doesn’t clear floats in this manner. So you can go into your template files and add in <hr class="clear" /> right *before* the closing div tag (the one that closes your #container div), and in your CSS, add in

    hr.clear {
    clear:both;
    visibility:hidden;}

    That will cause the #container to now clear both floats. You’ll have to find out what setting you have in your header (or whatever is above these fields) that is causing them to push down by such a margin.

    But yes, what I gave you *is* correct – it was just a starting point. The rest is “fiddling” until you get what you want.

    i cant help but say you are the man.. this has been a reoccuring problem for me. Thanks tons

    LOL – actually, I’m the “woman” if you don’t mind – but glad it worked out for you 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Position Issue’ is closed to new replies.
Skip to toolbar