Support » Plugin: Jetpack by WordPress.com » Portfolio showposts

  • Resolved Shoofly Solutions

    (@nomadcoder)


    I can’t get showposts to work to display the portfolios on a self hosted website using Blask & Jetpack. I don’t know if this is a Blask or a Jetpack issue but I can’t find where to change this setting and the shortcode doesn’t work.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support Fotis

    (@fstat)

    Hi there,

    I tested the portfolio shortcode with the Blask theme and I was able to display my projects to any post or page I inserted it.

    Here are the instructions on how to properly embed a portfolio project:

    https://en.support.wordpress.com/portfolios/portfolio-shortcode/

    Hi there! Thanks for passing the feedback over, although I’m bummed to hear you’re having trouble.

    Also, could you post your site’s URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    https://jetpack.com/contact-support/?rel=support

    The site is now self-hosted and no longer on WordPress.com.

    http://www.bereavementartists.com

    On WordPress.com, the setting to show how many portfolio items is on the ‘writing’ page.

    This option is missing in the jetpack settings on the self hosted site and the showposts shortcode setting does not seem to work.

    [portfolio include_type=”category” display_types=false display_tags=false columns=3 showposts=60]

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator πŸš€

    For the portfolio shortcode to work in WordPress’s new Block Editor, make sure that you are adding it in a Classic block: https://gogutenberg.com/blocks/classic/

    As for the settings, visit Settings > Writing in your site’s Dashboard, check “Enable Portfolio Projects for this site,” and save. Then, the option to choose the number of projects will appear below.

    If you don’t see any of that at Settings > Writing in your site’s Dashboard, switch on the “Custom Content Types” module via the All Modules view: https://jetpack.com/support/control-jetpacks-modules-on-one-page/

    Hello, if you follow the link you will see that Portfolio is active and 10 portfolios are showing up on the page. We would like more than that.

    Portfolios are already active in Settings>Writing.

    What is not there is the option to choose the number of projects to display.

    So, “Custom Content Types” is already on.

    Plugin Support KokkieH

    (@kokkieh)

    Hi there,

    I can see the setting for number of porfolio items without problem on a test site with Jetpack and Blask active.

    Just to make sure, are you looking at WordPress.com ->My Site ->Settings ->Writing? That option also appears in WP-Admin ->Settings ->Writing.

    But a better option here might be to just enable infinite scroll instead. Then new projects will load automatically once someone reaches the end of that page, rather than someone having to click a Previous button to see older projects.

    You can enable infinite scroll from the WordPress.com Writing Settings as well, in the “Theme Enhancements” section.

    I created a new post that hopefully clarifies that this is not a wordpress.com website or wordpress.com issue, that this is a self hosted website, so that we can start over.

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator πŸš€

    Hi there, to be clear, you can interact with your Jetpack site on WordPress.com too, that is one of Jetpack’s main features: https://jetpack.com/support/site-management/

    This is why my colleague is asking if you’re interacting with these settings on WordPress.com or in your site’s Dashboard.

    To be clear, here is what I see at Settings > Writing (/wp-admin/options-writing.php) in the Dashboard of a fresh WordPress 5.0.3 site, running Jetpack 6.9 with the Twenty Nineteen theme: http://cld.wthms.co/Xuf0Vp

    Once I check “Enable Portfolio Projects for this site.” and save, the choice of how many projects to display per page appears: http://cld.wthms.co/0yRB21

    Aha. So the trick is to go to WordPress.com and change the portfolio settings there. That worked. Thank you.

    It’s a bit confusing.

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator πŸš€

    You shouldn’t _need_ to go to WordPress.com for that, my screenshots were from the site’s Dashboard (not WordPress.com), but I’m glad that worked out regardless! πŸ™‚

    It wasn’t there on the site dashboard. And the shortcode didn’t work, but this fixed it so I’m happy now! Thank you!

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.