Support » Plugin: Jetpack by WordPress.com » Portfolio shortcode in Page is ignored with permalinks

  • Resolved Shaped Pixels

    (@shaped-pixels)


    I’ve discovered an odd behavior (a second time actually). I am setting up a demo site that is setup with a WordPress network (multisite) configuration. I made a Portfolio page (full width template) and used the shortcode method to load the portfolio in 3 columns. The problem I discovered is that when the site permalinks uses the default setting, the page with the shortcode works. However, if I use any other permalinks setting, the portfolio loads in the “Archives” template like a typical blog.

    This is happening on two different locations, the first is my local XAMPP setup with just a single instance of WordPress, and then the live demo site setup on a network for multisites (demos).

    At the moment, I will a permalinks setting other than Default to show you what is loads in: Portfolio Using Shortcode

    Any idea why the “page” is ignored when permalinks other than default used?

    https://wordpress.org/plugins/jetpack/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Could you let me know how you named that custom portfolio archive template file?

    Thanks!

    Hi Jeremy, thanks for the follow up….the only custom template file I have is for displaying the “single” portfolio item, which was named: single-jetpack-portfolio.php

    As for the page that displays the portfolio items using the shortcode method, this is a basic full width page template named: full-width.php (which is located in page-templates/full-wdth.php of the theme.

    Basically everything works when I use only the default permalinks setting, but not when I use a different one. The single-jetpack-portfolio.php template works though, it’s just the page with the shortcode doesn’t with anything other than default permalinks.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Thanks for the extra details!

    Could you edit that page, and let me know what the slug is, as shown on this screenshot?
    http://i.wpne.ws/Zipy

    For the “Portfolio” page I created with the full-width.php template, the permalink showing is:

    Permalink: http://demo.shapedpixels.com/shapedpixelspro/portfolio/

    And the front-end url that shows (current using the archive template) is:

    http://demo.shapedpixels.com/shapedpixelspro/portfolio/

    …and just for reference when I use the default permalinks setting:

    Portfolio

    Viewing a single portfolio item post (using the custom single jetpack portfolio template, displays this as the front-end url:

    Abstract Orange

    If you feel you might want access to the admin, let me know.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Thanks for all these details.

    That seems to be a common conflict between Custom Post Types and Pages. You can find a solution here:
    https://wordpress.stackexchange.com/questions/31512/custom-post-type-slug-page-slug-conflict-prevent-use-of-reserved-slug-on-pag/45152#45152

    I hope this helps.

    Thanks Jeremy for all this….although I did not use that solution, I decided rather than add yet more functions and filters to my theme, I decided to try changing the portfolio’s page slug from “portfolio” to project-portfolio and sure enough it worked. So you are correct, there is a conflict with the page slug being named the same as the custom post type. I would imagine this is the same for any other custom post type.

    I will still try out that one filter based solution locally and see how that works.

    Thanks again!

    UPDATE: I just tried that solution with the filters/function….looks like what it does is add a suffix to the slug like “portfolio-2” but the page name can still be “portfolio”.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Portfolio shortcode in Page is ignored with permalinks’ is closed to new replies.