Support » Theme: Virtue » Portfolio featured image

  • Resolved sem4186


    Hi all,

    I have a problem with the portfolio posts. Basically when I Set a featured image I can see that something is going on, because then I can select Remove featured image and there’s a gap in the box, but nothing is showing up.

    This is the snippet that is coming up:

    <p class="hide-if-no-js">
    	<a title="Set featured image" href="">
    	  <img width="1" height="1" src="" class="attachment-266x266" alt="download_20140505_183554">

    Why the img is with width and height = 1 ?

    And if I simply open the page I get as result a completely blank image, also the text disappears. As soon as I remove the featured image I am then able to open the page and see the text.

    I really want to create a portfolio carousel in the front page, but unfortunately I can’t.

    I’m on the free version.

    Thanks a lot,

Viewing 6 replies - 1 through 6 (of 6 total)
  • Try removing the part where it “gives” it the max hight/width.

    <p class=”hide-if-no-js”>

    <img src=”” class=”attachment-266×266″ alt=”download_20140505_183554″>


    I cant promise you that this works, but i hope so.

    If this works, you can always add a max width and max height.

    Hi Robin,

    thanks a lot for your reply. That can be good to solve the first part of the problem, which is the featured image not showing (i tried “live” with chrome and it’s working), but i’m left with the major problem, which is that if I use a featured image then the portfolio item will be a blank page (i can see that the body is set to 1px height).

    In addition to what i previously said, if I enable the portfolio carousel in the static home page then nothing will show in the page body, just the title.

    I don’t have any plugin installed, it’s a fresh website.

    Thanks again,

    Theme Author Kadence Themes


    Sounds like there is an issue with the image when you uploaded. Like wordpress couldn’t read it correctly or your server is not allowing the php to resize your images for things like thumbnails.

    So do some testing, try a different file type and try a different size.
    Try to view the image in your browser by click on the media link in your wordpress admin and opening the image. See if wordpress lets you edit the image.

    Post a link if you can.

    Kadence Themes


    thanks a lot for your reply.

    Yes I think that there might be a problem with the permission settings on my host.

    I can see that I have all my items from the Media –> Library panel.

    I can see the image if I go directly to it:

    But in the post I can’t see anything, it’s blank
    (don’t know if it makes sense)

    Edit: inspecting the page I can see that the image is there, but again with following code:

    <img width="1" height="1" src="" class="attachment-medium" alt="download_20140505_183622">

    Moreover, if I try to edit the image it says:
    Image data does not exist. Please re-upload the image.

    It’s that a problem with the permissions on the server that is hosting my website?


    Update: it is working with png files, I guess I will use only those from now on 🙂

    Thanks all for your support, really appreciate.


    Theme Author Kadence Themes


    I would contact your hosting company and see if they have any advice for you.

    Kadence Themes

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Portfolio featured image’ is closed to new replies.