Support » Plugin: Popups, Welcome Bar, Optins and Lead Generation Plugin - Icegram » PopUp still showing in mobile and tablets

  • Resolved atolvanen

    (@atolvanen)


    First of all: thank you for this great plugin. It has a great amount of options which makes it very versatile tool.

    I have an issue when viewing my website on mobile and tablet. In this plugin there’s display options for different platforms. Even tough I uncheck options for mobile and tablets, it still displays PopUps on those devices. I’m using Sony xperia Z1 compact as a phone and Samsung Galaxy Tab S 10.1 as a tablet. So both devices are Android and both are using Chrome mobile as web browser.

    When viewing the PopUp in my website on tablet, it looks fine, but on mobile I can see only few letters on the PopUp and I really want that the PopUp won’t show on mobile phones. Is this a bug or what?

    Hope you can help on this one.

    https://wordpress.org/plugins/icegram/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Here’s a screenshot from my mobile phone:
    http://www.imageupload.co.uk/5PNe

    Not very pretty or usable when viewing on mobile.

    False alarm! I figured this one on my self.

    The problem wasn’t about your plugin. I’m using ‘W3 Total Cache’ plugin on my website and after I disabled it, the PopUp started to behave just fine on mobile and tablet. So the problem was with cache options.

    I tested my website with Chrome mobile on phone and tablet. The PopUp isn’t showing up and that’s just what I wanted. When I turn on the option in Chrome ‘Request desktop site’, the PopUp shows up. After I uncheck the option, PopUp stays hidden. I mean it works exactly the way it’s supposed to. But only issue came with my old Nokia Lumia 800 with Windows Phone 7.8 and some old version of Internet Explorer mobile. It shows the PopUp, but it’s an old phone and old crappy web browser, so I’m not concerned about that.

    So the next thing in my todo-list is to learn to use cache-plugin.

    Plugin Author Icegram

    (@icegram)

    Happy to know Icegram’s working fine for you. Yes, W3 Total Cache needs to be disabled for the popup to showup. Incase of any other issues. Send us a mail at hello@icegram.com we’ll be happy to assist you 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PopUp still showing in mobile and tablets’ is closed to new replies.