WordPress.org

Forums

Simple PopUp
[resolved] Popup showing on every page (8 posts)

  1. JenniferG73
    Member
    Posted 2 years ago #

    How do I set the popup to only show on the homepage?

    Thanks,
    Jenn

    http://wordpress.org/extend/plugins/simple-popup/

  2. JenniferG73
    Member
    Posted 2 years ago #

    or I should say that when the form is filled out on the popup, it posts to mailchimp, and returns to a thank you page and displays the popup again.

    The popup is not showing on every page...only when the form posts and you are returned to the site.

    Thanks!

  3. iftomkins
    Member
    Posted 2 years ago #

    Yes! I have the same issue. You go to Mailchimp, come back, and then it pops up again. Not so good! I may have to try to write a custom script to stop it when a certain page is accessed?

  4. iftomkins
    Member
    Posted 2 years ago #

    Here's what I used to force-hide the two main popup elements on my 2 confirmation pages that mailchimp directs to. I placed it just inside the opening body tag, but anywhere inside the body tag should work.

    <?php if(is_page(664) || is_page(661)) { ?>
    <script>
    $(document).ready(function() {
    $("#boxes #dialog").css("display","none !important");
    $("#spmask").css("display","none !important");
    });
    </script>
    <?php } ?>

  5. iftomkins
    Member
    Posted 2 years ago #

    Oops! That doesn't seem to work. Oh well. Any other possible solutions?

  6. iftomkins
    Member
    Posted 2 years ago #

    Tried everything I can think of. Here are some of them:

    + removing the actions used in the SimplePop.php file on certain pages, called from functions.php
    + using this plugin to remove the actions using class and action name: https://github.com/herewithme/wp-filters-extras/
    + using the Plugin Organizer plugin to enable the plugin only on certain pages

    None of it works. This simplepop plugin is bulletproof!

  7. iftomkins
    Member
    Posted 2 years ago #

    Ok! Finally worked. Used this plugin: http://wordpress.org/extend/plugins/plugin-organizer/

    And ordered the plugin loading so that SimplePop loaded BEFORE the Plugin Organizer.

    Also, be sure to 1) enable selective plugin loading, 2) disable the plugin on each individual page.

  8. Jeff Sterup
    Member
    Posted 2 years ago #

    The best way to do it should be to...
    1. Enable selective plugin loading.
    2. Disable the plugin globally.
    3. Enable the plugin on the page where you want it to appear.

    If you didn't have selective plugin loading enabled before testing, plugin organizer wouldn't have disabled it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Simple PopUp
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.