Support » Plugin: Popup Maker - Popup Forms, Opt-ins & More » PopUp not working with iOS 11

  • Resolved zoe626

    (@zoe626)


    We have found that mobile visitors to our website on iOS 11 are unable to navigate through our pop-up form – the cursor does not appear so you cannot tell which text box is highlighted and you can’t view ticks in boxes – it makes completion of the form very difficult.

    If we try on iOS 10 – no problem, this is specific to those using 11.

    We have now had to disable the popup on mobile due to the poor user experience – despite it being one of our most successful conversion tools.

    Has anyone else experienced problems with this?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Robert Gadon

    (@yogaman5020)

    Hello @zoe626:

    Can you clone your site and move it to another remotely hosted server, then reactivate Popup Maker and publish the problem popup? We’d like to inspect the site url to see if we can isolate the source of the problem that you’re experiencing.

    pcburcham

    (@pcburcham)

    I’m pretty sure they are referring to the modal bug found in iOS 11: https://bugs.webkit.org/show_bug.cgi?id=176896
    I’m having the same issue with contact forms in modals (on iOS 11 in any browser app) as well. It is a known bug, and I just installed iOS 11.1.2 and the problem is still present.

    pcburcham

    (@pcburcham)

    Just to follow up. Having this problem is what brought me to this thread. After researching and testing settings, disabling the overlay worked for me. The cursor remains in the field boxes of the contact form (Contact Form 7) as expected. I also inched the form closer to the top edge of the screen and have the position set to top-center. The other settings under positioning are unchecked. I have the size set to Small 40%, but I don’t believe that is relevant to the issue. These settings allow the popup to scroll with the content on the screen. Not ideal, but maybe this will suffice and help someone else out until the bug is addressed.

    I’m running into this issue too. iOS 11.x and a popup with an input field. My case, formidable form in the popups.

    I found this: https://hackernoon.com/how-to-fix-the-ios-11-input-element-in-fixed-modals-bug-aaf66c7ba3f8 and https://stackoverflow.com/questions/46339063/ios-11-safari-bootstrap-modal-text-area-outside-of-cursor

    Do you guys have a solution for this? I’ve tried:
    .pum-container { position:fixed; width:100%; }
    It helped when first clicking in but jumps out if there is a dropdown in the input field. Also in a textarea, the cursor is below a couple lines from where it is suppose to be right after typing.

    Any suggestions?
    Thanks
    Dana

    I haven’t found a decent solution yet. All of the workarounds I’ve seen (that actually work) have negative side effects on other elements of the site and aren’t worth the effort. I’m still using my modals with the overlay disabled and it’s working, but it just kills the aesthetics. I’ve also read that the bug is still present in the latest developer beta of iOS also, so it could indeed be a while before it is addressed.

    Thanks. Disabling the overlay causes other issues for me.

    I was hoping PopUp Maker will offer a solution based on if the browser is from ios11.x .

    Living with it I guess until hopefully Apple releases a bug fix soon.

    Thanks
    Dana

    I have also run into that issue many times, Popup maker support group and I have been exchanging emails for quite some time and nothing for now..

    I am been trying other workarounds to make the entire popup to be fixed when entering in the input field, But I see no changes in Apple devices like iPad or iPhone. Other tablet, it works perfectly.

    I hope it can addressed and have some solution in the next version of popup maker.

    Regards,
    Krist

    Plugin Author Daniel Iser

    (@danieliser)

    @rdanamcd, @knight1431, @pcburcham – Just wanted to give you a heads up we have been tracking this for some time and attempted many different fixes. None really address the issue and it seems iOS is slow to get it fixed properly. They have closed the original issue as resolved.

    In the mean time we are indexing as much info on the matter as we can here: https://github.com/PopupMaker/Popup-Maker/issues/500

    I am closing this as I would prefer any further constructive discussion pertaining to possible solutions or new information can take place in the proper channel (github).

    Hello @knight1431, @rdanamcd, @pcburcham, @zoe626:

    With the release of iOS 11.3 on March 29, 2018, Apple fixed the problem described in previous posts on this thread. Please be sure to update your iOS 11 enabled device(s) and check then to ensure the problem is resolved.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘PopUp not working with iOS 11’ is closed to new replies.