• Resolved andres0379


    `Hello, I have an error with the plugin when I activate the Popup Maker.

    I raised the max_input_time to 300 but it still gives me the same error.

    The web is updated to the latest version 6.0.2 the plugin is updated and it is a new installation.

    I add below the error it generates.

    Warning: foreach() argument must be of type array|object, string given in /srv/vhost/gensasl.com/home/html/wp-content/plugins/popup-maker/classes/Model/Popup.php on line 680 Fatal error: Uncaught TypeError: array_values(): Argument #1 ($array) must be of type array, string given in /srv/vhost/gensasl.com/home/html/wp-content/plugins/popup-maker/classes/Model/Popup.php:703 Stack trace: #0 /srv/vhost/gensasl.com/home/html/wp-content/plugins/popup-maker/classes/Model/Popup.php(703): array_values('Array') #1 /srv/vhost/gensasl.com/home/html/wp-content/plugins/popup-maker/classes/Model/Popup.php(775): PUM_Model_Popup->get_conditions(Array) #2 /srv/vhost/gensasl.com/home/html/wp-content/plugins/popup-maker/classes/Model/Popup.php(869): PUM_Model_Popup->has_conditions(Array) #3 /srv/vhost/gensasl.com/home/html/wp-content/plugins/popup-maker/includes/functions/popups/conditionals.php(44): PUM_Model_Popup->is_loadable() #4 /srv/vhost/gensasl.com/home/html/wp-content/plugins/popup-maker/classes/Site/Popups.php(108): pum_is_popup_loadable(93160) #5 /srv/vhost/gensasl.com/home/html/wp-includes/class-wp-hook.php(307): PUM_Site_Popups::load_popups('') #6 /srv/vhost/gensasl.com/home/html/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters(NULL, Array) #7 /srv/vhost/gensasl.com/home/html/wp-includes/plugin.php(476): WP_Hook->do_action(Array) #8 /srv/vhost/gensasl.com/home/html/wp-includes/script-loader.php(2156): do_action('wp_enqueue_scri...') #9 /srv/vhost/gensasl.com/home/html/wp-includes/class-wp-hook.php(307): wp_enqueue_scripts('') #10 /srv/vhost/gensasl.com/home/html/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters('', Array) #11 /srv/vhost/gensasl.com/home/html/wp-includes/plugin.php(476): WP_Hook->do_action(Array) #12 /srv/vhost/gensasl.com/home/html/wp-includes/general-template.php(3042): do_action('wp_head') #13 /srv/vhost/gensasl.com/home/html/wp-content/themes/Divi/includes/builder/frontend-builder/theme-builder/frontend-header-template.php(11): wp_head() #14 /srv/vhost/gensasl.com/home/html/wp-content/themes/Divi/includes/builder/frontend-builder/theme-builder/frontend.php(216): require_once('/srv/vhost/gens...') #15 /srv/vhost/gensasl.com/home/html/wp-content/themes/Divi/includes/builder/frontend-builder/theme-builder/frontend.php(247): et_theme_builder_frontend_override_partial('header', '', 'wp_head') #16 /srv/vhost/gensasl.com/home/html/wp-includes/class-wp-hook.php(309): et_theme_builder_frontend_override_header(NULL) #17 /srv/vhost/gensasl.com/home/html/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters('', Array) #18 /srv/vhost/gensasl.com/home/html/wp-includes/plugin.php(476): WP_Hook->do_action(Array) #19 /srv/vhost/gensasl.com/home/html/wp-includes/general-template.php(38): do_action('get_header', NULL, Array) #20 /srv/vhost/gensasl.com/home/html/wp-content/themes/Divi/page.php(3): get_header() #21 /srv/vhost/gensasl.com/home/html/wp-includes/template-loader.php(106): include('/srv/vhost/gens...') #22 /srv/vhost/gensasl.com/home/html/wp-blog-header.php(19): require_once('/srv/vhost/gens...') #23 /srv/vhost/gensasl.com/home/html/index.php(17): require('/srv/vhost/gens...') #24 {main} thrown in /srv/vhost/gensasl.com/home/html/wp-content/plugins/popup-maker/classes/Model/Popup.php on line 703 Ha habido un error crítico en esta web.

    I hope you can help me.

    Thanks in advance.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Bel


    Hi @andres0379

    Thank you for getting in touch, and we’re sorry a warning and error shows when activating Popup Maker.

    Could you try the troubleshooting guide to isolate a theme/plugin conflict?


    Should the issue persists, we would like to take a closer look.

    Can you install Temporary Login Without Password plugin to give us admin access?

    Just copy and send the login link shown here in our support website for security.

    Here’s how to:
    1. Go to https://wppopupmaker.com/support/#submit-a-support-ticket
    2. Click Other Support
    3. Fill in the form
    4. Click SUBMIT

    Here’s a screen capture for your reference: https://share.wppopupmaker.com/geudGzB4

    Thank you, and we look forward to your response.

    Plugin Author Daniel Iser


    @andres0379 – That error to me indicates that you have at least one popup, and it’s settings, at least condition list has been corrupted somehow.

    The lines before that error check that the popups condititon setting is not false, so the value must be a truthy one such as a string of text, but not an array which we are expecting.

    Never seen this before so we would need to try and duplicate it if you can give us some steps.

    Would also be helpful seeing what the raw value for that popup’s popup_settings meta in the DB is.

    Thread Starter andres0379


    Hello Daniel
    The problem is solved, thanks to the support.
    It was due to a window that did not meet the required settings.
    Since this popup was created with a page builder like Divi, it had to use the "Content Only - For use with page builders or block editor" theme.
    Thank you very much for your attention
    Have a good day
    Plugin Support Kim L


    Hi @andres0379,

    Thanks for the update and we’re glad that’s been sorted out!

    I’ll now mark this thread as resolved. Feel free to open a new thread if you have any other questions.

    Have a great day as well!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Popup Maker Error on line 680 and line 703’ is closed to new replies.