Support » Plugin: WPD Beaver Popups » popup from a link?

  • I create a popup and get the address:
    https://bbplain.sitedistrict.com/?wpd-bb-popup=test-popup

    Then use that as a custom link in my navigation menu. Popup works great, but I can’t close it either by clicking the close icon or the overlay background.

    Same issue with triggering the popup with an html link e.g.
    this is some text with a link to a <a href="https://bbplain.sitedistrict.com/?wpd-bb-popup=test-popup">popup</a>

    Any suggestions?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author smarterdigitalltd

    (@smarterdigitalltd)

    Hi Pieter

    Thanks for getting in touch.

    The reason for this is the link will work like a regular page. So you are being navigated to the page of the popup, instead of the popup ‘popping’ up above your other content.

    Currently, it’s not possible to make a popup from a link, but it is very high on the priority list as lots of people have requested it.

    I will add your name to the list so that once I have an update on this feature I can notify you 🙂

    Thanks again Pieter
    Doug

    Please add me to this list as well. Also, I’ve tried styling a button to look like a link, but I’ve found what seem like bugs.

    I can’t use a button to open a popup, unless the popup is already assigned to a scope (On Entrance / On Exit / On Scroll).

    Also, if I save a button as a saved row or module, then pull it into a post with a shortcode, I can’t get the button to activate a popup.

    Cheers,

    Plugin Author smarterdigitalltd

    (@smarterdigitalltd)

    Hi @richardu

    Absolutely – I’ve added you to the list.

    I’ll check out the other points you mention too.

    Hello,

    I just encountered the same problem as rechardu.

    In beaver builder when I attach a popup to a button, then save.

    Once I click on the button, it doesn’t show.

    I then went into popup manager and created an on entrance popup. And just delayed it for like 1200 seconds. So basically, it won’t show.

    Then once I click on the button, the popup on the button displays.

    I figured the above portion out, before I read this forum.

    I know this is a temp fix. Do you have a suggestion as to why this is happening?

    Thank you in advance,

    Jerry

    Plugin Author smarterdigitalltd

    (@smarterdigitalltd)

    Hi Jerry

    Could you please confirm for me if it is a saved module button you mean?

    Regards
    Doug

    I’m so sorry, I never got this in my email.

    Yes, it’s a Beaver Builder module button

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘popup from a link?’ is closed to new replies.