Support » Plugin: Popup Builder - Responsive WordPress Pop up - Subscription & Newsletter » Popup displays even when “Enabled (show popup)” is off

  • Resolved Larry Daniele


    After updating to Popup Builder v3.0.3, an old popup is appearing on our Home page when the “Enabled (show popup)” setting is off for it (and for all popups).

    I’ve tried repeating the problem in a number of browsers and an “incognito” window (with no cache or cookies) and it is repeatable in all cases.

    As a work-around, I’ve deactivated the plugin.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Sygnoos


    Hello @larrydaniele,
    Could you please try to setup popup on any temporary page and then disable it and send the URL of the page to us so we can check the issue live?
    In case you don’t want to share it here please .

    Thank you for cooperation.

    Ditto OP.

    Hi @sygnoos,

    I updated to Popup Builder v3.0.4, but that didn’t help.

    I created a test page, but that didn’t demonstrate the problem. The problem only occurs on the Home page. Unfortunately, I can’t leave the plugin activated given its impact on the Home page.

    I’m sorry if this makes it more difficult to debug. We are not using the plugin currently, so we’re not looking for solution. Just trying to report the problem and perhaps help others if they encounter the problem.

    Good luck!


    Plugin Author Sygnoos


    Hey @larrydaniele,
    This kind of issue may appear also if you are using a shortcode. In this case, we don’t disable the popup as we think if the person inserted manually that means he/she wants the popup to be always visible.

    After some discussion with our team, we have decided to disable all the popups even if you have setup it via shortcode or onclick class.

    Hope you will give it a try in future.



    Will this change be rolled out via plugin update soon?
    Many thanks in advance.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Popup displays even when “Enabled (show popup)” is off’ is closed to new replies.