• Resolved famarinu

    (@famarinu)


    Hi,
    how can I not display the pop-up every time I switch pages? I realized this problem with the new version of wordpress, before it gave me this problem.
    Thank you.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Hello @famarinu:

    Please refer to this documentation article: http://docs.wppopupmaker.com/article/340-create-your-first-popup

    In particular, refer to items #3 (Conditions) and #6 (Set a Popup Cookie). Note the following from the article about ‘Conditions’:

    If you don’t set a condition, the popup will activate on every page of your site.

    That’s probably what’s happening on your site.

    Because you’re using an email subscription form from MailPoet, you will need to set a cookie via Manual JavaScript on form submit success. From the documentation article:

    All other form plugins require setting a cookie via ‘Manual JavaScript’ and passing in a custom PHP and jQuery script to your site theme to submit and close a form.

    Related article: Close Popup and Create Cookie When a Form is Submitted

    You can avoid working directly with code if you change your email form to either Ninja Forms, GravityForms, or Contact Form 7 (it’s explained in the article referenced above). Note: We are a Ninja Forms affiliate. Both our companies provide support for each other’s products.

    • This reply was modified 2 years, 9 months ago by Robert Gadon.
    • This reply was modified 2 years, 9 months ago by Robert Gadon.
Viewing 1 replies (of 1 total)
  • The topic ‘popup display’ is closed to new replies.