Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Popular Posts not working after update

  • Resolved gorbyoz

    (@gorbyoz)


    After the last update the Popular posts section is not showing any posts. Also in my dashboard the Top Posts and the Top Searches aren’t working either.

    I have version 4.5.

    • This topic was modified 4 years ago by gorbyoz.
    • This topic was modified 4 years ago by gorbyoz.
Viewing 15 replies - 16 through 30 (of 41 total)
  • richmurphycctv

    (@richmurphycctv)

    We are seeing this issue as well. Popular posts disappeared. It’s been over a day now.
    http://america.cgtn.com/

    richmurphycctv

    (@richmurphycctv)

    maybe related to problem? Our site stats show this:

    Top Posts
    Sorry, nothing to report.
    Top Searches
    Sorry, nothing to report.

    gje

    (@gje)

    I’m afraid we need to go back one update, but how do we get there?

    greatgrape

    (@greatgrape)

    It’s been over 24hours still no top posts showing
    http://www.pillarboxblue.com/

    greatgrape

    (@greatgrape)

    It’s been over 24hours still no top posts showing
    http://www.pillarboxblue.com/

    quanin

    (@quanin)

    I have the same problem. However, if I go to the stats page from within the WP dashboard and drill down to the top posts summary, all the info’s there. I can confirm I’m getting visitors to the site, but the issue still persists.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    This only appears when logged out. Is that a public default if no posts are in the list?

    You’re right, I hadn’t realized it was the last post. That’s indeed the fallback for non-admins; you’re the only one who will see the “Want more traffic?” message.

    I ran some more tests and discovered the source of the problem. I’m working on a fix right now. Sorry everyone for the trouble!

    Until a fix is available, if you feel comfortable editing PHP files you can revert the changes outlined here to solve the issue:
    https://github.com/Automattic/jetpack/pull/5968/files

    If you change https://stats.wordpress.com/csv.php into http://stats.wordpress.com/csv.php on line 1197 of the modules/stats.php file in the jetpack directory, you’ll get your top posts back.

    Sorry again! I’ll post again here as soon as a fix becomes available.

    Veken

    (@veken)

    Thanks that fixed it immediately.

    phloH

    (@phloh)

    Thank you for the great support!

    Laz

    (@lazharichir)

    Does not work for me either (home page, most popular posts):
    https://breedingbusiness.com/

    I manually call the function in my own code:
    $top_posts = stats_get_csv( ‘postviews’, “days=10&limit=8”)

    fixed it with your code hack.

    • This reply was modified 4 years ago by Laz.
    gje

    (@gje)

    Thanks

    Seems to work for me.

    gorbyoz

    (@gorbyoz)

    I will try. (Sorry, didn’t see this last page)

    • This reply was modified 4 years ago by gorbyoz.
    gorbyoz

    (@gorbyoz)

    http://stats.wordpress.com/csv.php

    This worked for me. Thanks.

    howzbuy

    (@howzbuy)

    Same problem after Update to my website too
    message “There are no posts to display”

    http://howzbuy.com/

    shawnrouse

    (@shawnrouse)

    Worked for me too, thanks.

Viewing 15 replies - 16 through 30 (of 41 total)
  • The topic ‘Popular Posts not working after update’ is closed to new replies.