Support » Plugin: WordPress Popular Posts » popular post 403 console error on the website

  • Resolved madhuramalgoworks

    (@madhuramalgoworks)


    Hi Team,
    I am facing an issue with the popular post plugin. The issue is related to the 403 status which I am getting in the console.
    /wp-json/wordpress-popular-posts/v1/popular-posts 403

    I am using the swift performance plugin on my website. Please see the below scenario for the error:-
    1. When I disable the minify HTML then it’s working fine.
    2. When I clear the website cache then it’s working fine for some time.
    3. Exclude the popular post javascript then it’s working fine for some time.

    I need a permanent fix for this issue. Please guide me on how can we solve this issue in the plugin.

    Thanks
    Madhuram

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Héctor Cabrera

    (@hcabrera)

    Hi @madhuramalgoworks,

    I just tried the Swift Performance Lite plugin and WordPress Popular Posts was able to work normally with the Minify HTML option enabled so I don’t think that’s your problem. The issue is likely related to this:

    When I clear the website cache then it’s working fine for some time.

    Make sure that Swift Performance’s Cache Expiry Time (Swift Performance > Caching > General) is set to 12 hours (that’s the default value) and that Cache Expiry Mode is set to Time based mode.

    Apply those changes, clear Swift Performance’s cache and check again. WPP should track visits normally after that.

    If that doesn’t fix the problem and you’re still seeing 403 errors then please go to Settings > WordPress Popular Posts, click on the Debug link (top center of the screen) and share the info you see there here so I can have a look.

    Thread Starter madhuramalgoworks

    (@madhuramalgoworks)

    Hi,
    I am using the free version of the Swift Performance Lite plugin and not able to see the above-mentioned settings.

    Make sure that Swift Performance’s Cache Expiry Time (Swift Performance > Caching > General) is set to 12 hours (that’s the default value) and that Cache Expiry Mode is set to Time-based mode.

    Please confirm are you using the free plugin or paid version.

    Also you can see the below information which we can see in the debug section:-

    Plugin Configuration
    Performance Nag: Dismissed
    
    Log Limit: No
    
    Log Views From: Everyone
    
    Data Caching: Yes, 1 minute
    
    Data Sampling: No
    
    External object cache: Yes
    
    WPP_CACHE_VIEWS: No
    
    System Info
    PHP version: 7.4.18
    
    PHP extensions: Core, date, libxml, openssl, pcre, zlib, filter, hash, Reflection, SPL, session, standard, sodium, apache2handler, mysqlnd, newrelic, PDO, xml, bcmath, bz2, calendar, ctype, curl, dba, dom, mbstring, FFI, fileinfo, ftp, gd, gettext, gmp, gnupg, iconv, igbinary, imagick, imap, intl, json, ldap, exif, msgpack, mysqli, pdo_mysql, Phar, posix, readline, redis, shmop, SimpleXML, soap, sockets, ssh2, sysvmsg, sysvsem, sysvshm, tokenizer, xmlreader, xmlrpc, xmlwriter, xsl, zip, memcached, Zend OPcache
    
    Database version: 5.7.34-37-log
    
    InnoDB availability: DEFAULT
    
    WordPress version: 5.7.2
    
    Multisite: No

    Thanks
    Madhuram

    Plugin Author Héctor Cabrera

    (@hcabrera)

    I am using the free version of the Swift Performance Lite plugin and not able to see the above-mentioned settings.

    Here:

    Also you can see the below information which we can see in the debug section

    You didn’t include the list of active plugins, I need that as well.

    Thread Starter madhuramalgoworks

    (@madhuramalgoworks)

    Hi thanks for the reply, we are using the Nginx server, and not able to see the mentioned sections.

    Thanks
    Madhuram

    Plugin Author Héctor Cabrera

    (@hcabrera)

    Using nginx or Apache not relevant here. No idea why the section doesn’t show up for you, I have the same version of the plugin and I can see it just fine.

    Reach out to the developers of the Swift Performance plugin and have them assist you with that.

    (…) you can see the below plugins list

    Thanks.

    At first glance nothing looks out of place, except maybe that you seem to have two active caching plugins: Swift Performance Lite version 2.3.5 and WP Engine Advanced Cache Options version 1.3.3. I’d recommend using one or the other, not both at the same time.

    Plugin Author Héctor Cabrera

    (@hcabrera)

    Marking as resolved due to inactivity.

    OP, if there’s anything else I can do to help please leave a comment below.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.