Support » Plugin: Popup Maker - Popup Forms, Optins & More » Pop up wont open

Viewing 6 replies - 1 through 6 (of 6 total)
  • I second this bug. The newest plugin is completely broken. It’ll also break other javascript code on the site. I recommend rolling back to 1.7.24 until 1.7.26 is out.

    Plugin Author danieliser

    (@danieliser)

    @farokhheidari – Sounds like your site is blocking loading JS files from the /wp-content/uploads folder for some reason. Try disabling Asset Caching via Popup Maker settings. Should revert to the old way loading multiple JS files from the plugin folder itself. v1.7 added this over 3 months ago, so you must just be updating from an older version. v1.7 attempted to improve performance by merging all of our JS, CSS, Custom JS & CSS, Extension JS & CSS etc into a single JS & CSS file that is saved to uploads. For some reason 1/1000 or so sites are seeing this issue where its not allowed for some reason.

    The other related but different possibility is that your site doesn’t use the standard wp-content/uploads path, but that would generate a 404 not a 403 error.

    @clammy77 – Your issue is unrelated. Are you using page caching? If so that is the reason you saw any issue at all. You are correct that v1.7.26 will address it, but only by adding an empty variable that isn’t needed if your page caching was cleared.

    Here was the issue:

    Our JS file changed and gets loaded with new code, The new code changed a variable name. Your page cache didn’t get cleared and the variable was still rendered in that cached page as the old one, thus generating errors.

    Hope that helps.

    @danieliser nope, no cache. the error in console shows the pum element couldn’t be defined, and it also broke other javascript code on the site. we’ve tested multiple times and also cleared cache. We had to revert to 1.7.24 for the site to function properly again.

    @danieliser
    I updated to the very last version, and I got this in my concole:

    JQMIGRATE: Migrate is installed, version 1.4.1

    Failed to load resource: the server responded with a status of 403 (Forbidden)
    http://www.lingaline.com/wp-content/uploads/pum/pum-site-scripts.js?defer&generated=1528447303&ver=1.7.27

    Uncaught ReferenceError: PUM is not defined
    at HTMLAnchorElement.onclick
    http://www.lingaline.com/test200/?preview_nonce=0bf6b719b4&preview=true

    Also, I tried Disabling caching via Popup Maker setting, and still no luck.

    I installed more than ten other plugin, all of which work, but do not offer me the functionality that I am looking for (which I found in your plugin on my local)

    Looking at the number of five stars it got, I can only blame my own luck 🙂
    I would like to rate it 5 stars as well because I know how powerful it is.

    If you found a way around this please let me know.

    Thanks for your time.

    AND I cannot revert to previuos versions bevause it is the first time I am installing this.

    farokhheidari

    (@farokhheidari)

    HI

    The latest update did it 🙂

    Disabled Asset Caching and it worked.

    Thank you.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.