Support » Plugin: GDPR Cookie Consent (CCPA Ready) » Pop UP translate – Not work

  • Resolved k12comunicacion

    (@k12comunicacion)


    Hi.
    I use the Spanish translation in my website. But I have seen that popup shows text strings in English, even though they are translated in the Spanish files.

    The strings are:
    Show more
    Necessary
    Not necessary
    Disabled
    Always – enabled

    I use the loco-translate plugin to complete the remaining translations or customize them. The plugin warns that the .pot template does not exist so it does not support translation customizations. Customizations should be made on the main language file, and that is a problem because updating the plugin would lose the customizations.

    I have wpml, but I prefer to use Loco-translate because the translation process is cleaner since it is file level and not database.

    Looking forward to hearing from you
    Best regards
    Pedro

Viewing 1 replies (of 1 total)
  • Plugin Author webtoffee

    (@webtoffee)

    Hi @k12comunicacion,

    Spanish translations of the mentioned strings are already included in the plugin files. It might the WordPress cached translation of a previous version causing the error.

    Please update the plugin to the latest version and check if there is 2 files with below given names in the wp-content/languages/plugins/ directory. If yes, please delete those files so that the translations will be loaded from the plugin files itself.

    /wp-content/languages/plugins/cookie-law-info-es_ES.mo
    /wp-content/languages/plugins/cookie-law-info-es_ES.po

    Hopefully, this would fix the issue.

Viewing 1 replies (of 1 total)
  • The topic ‘Pop UP translate – Not work’ is closed to new replies.