Support » Plugin: Woocommerce Upsell Popup » pop up not working

  • Resolved webdev



    I added the plugin and created the upsell and cross sell products however the pop up from the add to cart button does not display 🙁 The add to cart goes straight through to the checkout.

    Could you please advise how I can troubleshoot?


Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi Felicity,

    Are you sure you have set up everything correctly?

    A few possibilities for the popup not showing up:

    1. Your upsell product is out of stock, has no price, or does not exist.
    2. You didn’t enable the popup on that product.
    3. You enabled the popup but the upsell field is empty.

    Please check out the plugin documentation page here:

    Take a look at the demo site here:

    Also, the free version works differently than the PRO version of the plugin. With the free version, you can only have ONE upsell product per popup. This upsell product is set up through the plugin’s custom field.

    If you want to be able to use Woocommerce Linked Products (upsells and cross-sells), please upgrade to PRO.

    Thread Starter webdev


    thanks for the response – I have it working now however there is an error message sitting behind the pop up – could you please see here and advise:

    Also I have checked your demo and the layout is much nicer than the plugin as it uses an add to cart button rather than the Yes / No button. Could you please advise how we use the add to cart button and also change the text of the pop up message?

    Thanks again

    Please check your Woocommerce setting:

    Go to Woocommerce > Settings > Products > General > Shop pages.

    And then for ‘Add to cart behaviour’, uncheck ‘Redirect to the cart page after successful addition’.

    If you’re still seeing the error, try switching to a WordPress default theme and see if the problem goes away. If it does, it’s the problem with the theme.

    The add to cart button appears on your popup if you have 2 or more upsell products displayed on your popup. This is a feature in the PRO version.

    To change the text on the popup, you have to upgrade to PRO. Or if you are comfortable with action hooks and filters, you can use gettext filter to change the text.

    Thread Starter webdev


    I have changed the site themes and the error message is still present behind the pop up box.

    The Woocommerce you have on your site is Woocommerce version 3.5.3. We recommend updating to the latest version (4.0.1). But please remember Woocommerce 4 is a major update and requires php 7, if you’re not ready to start using Woocommerce 4, you could at least upgrade to 3.9.0.

    We will look into this bug and will fix it in the next update.

    We checked your site again and it appears you are using SG Optimizer plugin. It’s something to do with SG Optimizer’s supercacher, both plugins might not work very well together. Try emptying all the cache generated by SG Optimizer, and then disable the plugin temporarily, see if the error goes away.

    Thread Starter webdev


    I have turned off supercache and it is ok now. I’m interested in the pro version but I am worried that the layout is really unappealing – are you confident that it is vastly improved in the pro version?

    You can create your own layout (template) using the pro version. We can work with you to create the layout that you like if you find what the pro version offers is not up to your taste.

    Take a look at the screenshots found on the pro plugin page here:

    You might get an idea of what the pro version can offer.

    Again, if it’s not up to your taste, we can help re-style your popups.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘pop up not working’ is closed to new replies.