Support » Plugin: Spreadshop Plugin » Poor Performance and Support

  • Trying to get support for the issues with the plugin is nearly impossible. Spreadshop will tell you that you need to review some development articles when you tell them there is an issue with their plugin and the current version of WordPress. Its a compatibility issue because, as of the writing of this rating they haven’t updated the plugin in over 7 months, meaning it has not been certified to work with the last 3 major releases of WordPress.

    They push using the plugin a lot when you are new to SpreadShop. The fact that support and performance were sub-par left a bad taste in my mouth. Don’t push something you don’t actively support and update.

  • You must be logged in to reply to this review.