• Was looking forward to test this plugin out but was rather disappointed after activated it. I use WordPress with Roots. And getting several php errors.

    Poorly coded, a great example of this follows:

    $parse_uri = explode( 'wp-content', $_SERVER['SCRIPT_FILENAME'] );
    require_once( $parse_uri[0] . 'wp-load.php' );

    Include wp-load.php is not a best pratice.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Justin Greer

    (@justingreerbbi)

    Forum Moderator

    Hi,

    Sorry you had a poor experience with the plugin and thanks for the honest review.. We take all the reviews and opinions into consideration. If you could provide some of the PHP errors that you mentioned, we can work to fix them for future releases.

    Plugin Author Justin Greer

    (@justingreerbbi)

    Forum Moderator

    @lindesvard

    We are working to release an updated version by August 21, 2015 EOD. The update will use the template_include filter which will replace the direct calling of wp-load.php.

    Thanks for pointing this out and please do not hesitate to point anything else out!

    Justin

    Plugin Author Justin Greer

    (@justingreerbbi)

    Forum Moderator

    The plugin has been updated. Please update to the latest version.

    Thanks

    Plugin Author Justin Greer

    (@justingreerbbi)

    Forum Moderator

    I wanted to reach out to you and see if the issue was resolved with the latest version of the plugin? Maybe you could revise your review if so!

    Thanks

    Thread Starter lindesvard

    (@lindesvard)

    Hi Justin!

    I havent had the time to review your new update. I actually started to digg in into your plugin yesterday and managed to cleanup/improve your plugin a bit (so now it works fine with Roots/Bedrocks installation). I gladly share the changes with you. But I will test the new update as soon as I’m back to work on Monday!

    Thread Starter lindesvard

    (@lindesvard)

    Hi again Justin!

    Have tested the new version now (3.1.8). It worked better then the other versions. I still get an php warning

    is_writable(): open_basedir restriction in effect. File(/) is not within the allowed path(s): (/ebs/www/:/tmp) in <strong>/ebs/www/site/current/web/wp/wp-admin/includes/misc.php</strong>

    This error occurs when you call flush_rules every request. This call should you make on plugin activation instead. For WP Docs

    Because this function can be extremely costly in terms of performance, it should be used as sparingly as possible – such as during activation or deactivation of plugins or themes. Every attempt should be made to avoid using it in hooks that execute on each page load, such as init.

    With my changes everything working just fine! Contact me if you wanna see the changes.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Poor code’ is closed to new replies.