Support » Plugin: Polylang » Polylang/Divi search conflict

  • I’m using Polylang on a site that uses a child theme of Divi. The site is in development both live and locally. I realized today that the search feature isn’t working at all on either version. Every search returns a 404.

    I switched to a default theme on the local version and the search worked, so at first I thought it was just the theme that was causing a problem.

    Then I switched back to Divi child theme and disabled all plugins. The search worked again. Testing plugins one by one showed me that the search stopped working as soon as I re-enabled Polylang.

    I confirmed this theory on the live version of the site: when Polylang is activated on this site with Divi, the search feature does not work at all. When Polylang is deactivated, it works again.

    Can you offer any insight as to how I can fix this, or is there more testing I should do? The search function is going to be a crucial feature of this site.

Viewing 5 replies - 1 through 5 (of 5 total)
  • I seem to have resolved this by simply re-saving my settings in the Polylang settings page. Not clear on why this worked, but glad it did.

    Actually need to re-open this. Polylang appears now to be breaking my search of custom post types, which I hadn’t been testing for earlier. My previous solution (simply re-saving the settings) doesn’t work for this issue.

    I am using a function that allow me to search all posts, all pages, and all custom post types. When Polylang is deactivated, search works well. When it’s active, custom post types are not returned in searches.

    what function is this that you are talking about? It is a plugin or a function your wrote in your functions.php file?

    It happend to me as well…
    I notice that the error occurs because of polylang change the url of the search results page.
    So, in order to fix that, you need to go at the polylang settings and open the “settings of URL modifications” and check the checkbox on the bottom right that change the homepage URL to have the language code instead of the page ID.

    I hope that this help you.

    Thanks you @filipemoreira ! Your solution helped me a lot, you solved my problem !
    😘

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Polylang/Divi search conflict’ is closed to new replies.