Support » Plugin: Polylang » Polylang not working for the home page

  • alnajm

    (@alnajm)


    Hello

    Polylang is not working for the home page in our website. You can notice that the menu is still in Arabic even though the English language is chosen.

    Please help me out.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Thread Starter alnajm

    (@alnajm)

    Can I Chat with you?

    Thread Starter alnajm

    (@alnajm)

    Your plugin is forcing links for my pages, this is big mistake.

    Anonymous User 13603639

    (@anonymized-13603639)

    Please note, Polylang is a free plugin. Everything the developer is doing, is for free. The users of this communitiy are answering question for free.
    So, you can not expect an answer into minutes.
    If you have trouble and need a quick help, pay a WordPress developer who investigates your fault.

    Otherwise you should give as much information as you can to help others to help you.
    And wait, until an answer will be provided.

    Thread Starter alnajm

    (@alnajm)

    lachender_engel Thank you for your explanation.

    Meanwhile, I ask anybody who can help to help me out.

    1)The language switcher is not working for the home page of my website:
    http://yahmarentacar.com/en/home/

    2)Also, the Polylang plugin does not give the option to put 2 languages for the “site title” and “tagline”

    mikegalsal

    (@mikegalsal)

    We have the same problem, the home page is not configured in English.
    We have installed in teinogal.com client page but it has caused a problem.

    The original language is Spanish, but if we select the English language (secondary), it opens a page that does not exist, it is a page that contains all the pages in one, it is as if polylang had armed its own page containing all the pages. the correct thing would be to select HOME, but it does not.

    Why?. How can I choose Home by clicking on English?

    Anonymous User 13603639

    (@anonymized-13603639)

    It seems you both do not understand how Polylang works.
    Check this out https://polylang.wordpress.com/documentation/setting-up-a-wordpress-multilingual-site-with-polylang/translating-posts-or-pages/

    Technically you do not translate a post or page but you create a new one (new ID). The cool feature of Polylang is to link the posts/pages together, so Polylang can handle it as a translation.

    Hello,

    I am trying to install your fee plugin and have run into a problem regarding the front page, which “The chosen static front page must be translated in all languages”.

    The questions is if only your Pro version all for this change?

    Have tried to follow instructions from this page; https://polylang.pro/doc/define-your-home-page-as-a-static-page/

    Hope you can help.

    Cheers,
    Tom

    When I use your plugin the homepage doesn’t appear like it should be (a lot of blocks missin)

    Same problem

    We have a catalan home (mysite.com) and when we create the traduction mysite.com/es (2nd language) is a page that contains all the pages in one, it is as if polylang had armed its own page containing all the pages including examples of the wordpress theme we use.
    I follow https://polylang.wordpress.com/documentation/setting-up-a-wordpress-multilingual-site-with-polylang/translating-posts-or-pages/ instructions accurately but the translated page has an URL mysite.com/es/home-2 and the URL of second language home is mysite.com/es. Is there a way to force URL to another one when you click on the 2nd language flag?

    Any idea? Thanks!!

    Egishooter

    (@egishooter)

    Hello everyone,

    First of all thank you to the Polylang team for the great plugin. It is really useful for my de/en/es website.

    There is only one issue: I have the same problem as tfatzler: I cannot set the homepage and get the “The chosen static front page must be translated in all languages.” error.

    In the tutorial it says, that in languages/Settings/URL Modifications I can check a box called “the front page url contains the language code… “https://polylang.pro/doc/define-your-home-page-as-a-static-page/

    This same box does not appear in the recent version of polylang. Maybe there was a problem with the lates wp-updade.

    Does anyone know, how the homepage can be set manually? Or has another solution?

    I would be really grateful.

    Best Egishooter

    PS I meanwhile had to set the blog page as first page. Thats OK but no ideal

    Egishooter

    (@egishooter)

    Hello,
    it Egishooter again. I think I just found the solution to the abovementioned problem (static homepage) and want to share it here:

    I had the lingotek plugin installed. It seems, that lingotek creates for every translaten a new individual page (and as such listed in all pages), where as the standard Polylang pages are listed as one page with several translations.

    It seems, that Polylang does not recognise the different individual pages as translations of one another.

    My solution:
    I deinstalled lingotek and the creation of a static homepage worked just fine.
    The translations I am doing manually. Which is ok, as I have a very small site.

    I am not sure yet, what to do with my larger pages, though.

    I hope that was helpful!

    Take care, Egishooter

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Polylang not working for the home page’ is closed to new replies.