WordPress.org

Support

Support » Plugins and Hacks » Polylang » Polylang not linking to corresponding page when changing language

Polylang not linking to corresponding page when changing language

  • Dear Polylang,

    Firstly thank you for the plugin, really good work.
    I am having some difficulties with the transition from one language to another. Whenever I change languages it always takes me back to the homepage. Is there any way to change the settings to make it link to the corresponding page when changing language. For example if I am on the about page it, when you click the language button it opens the about page in the other language?

    I have a static front page, and my settings are as follows:

    The language is set from the directory name in pretty permalinks
    Remove /language/ in pretty permalinks
    The front page url contains the language code instead of the page name or page id
    Activate languages and translations for media
    Everything is ticked to synchronize.

    Many Thanks for your help,

    Gale

    https://wordpress.org/plugins/polylang/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Chouby

    @chouby

    On admin side, did you specify that you about page in one language is the translation of the about page in the other language?

    I have specified that one page is a translation of the other. This is happening with all pages on my website and they all have a specified translation. Is there a site wide setting somewhere?

    Plugin Author Chouby

    @chouby

    So if I well understand, when editing a page, you can see the correct title of the translation in the languages metabox. Correct?

    Could you check that you correctly setup the language switcher? There is an option “Forces link to front page” that you should keep unchecked to obtain what you want.

    If everything is ok in your settings, could you try to de-activate all other plugins and switch to a default theme then activate your theme and other plugins one by one to check if it comes from a conflict?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Polylang not linking to corresponding page when changing language’ is closed to new replies.
Skip to toolbar