Support » Plugin: W3 Total Cache » Polylang language switcher no longer working

  • Twice today I encountered a problem that the Polylang language switcher on the homepage was no longer working. Where I normally land on the Dutch version of the page I was now redirected to the English version and clicking the Dutch flag on top kept on redirecting me to the English version.

    The only way I could fix this was by purging the cache but a few hours later the same happened again.

    The problem only seemed to occur on desktop. I could reach the Dutch page on my mobile.

    As this seemed to be something related to caching and now happened for the first time after I have installed W3 Total Cache yesterday I think it must be related to this plugin.

    I have the default settings for page cache.
    This is what’s enabled:
    – Cache posts page
    – Cache SSL
    – Don’t cache logged in users

    I could just stop caching the front page but as I don’t quite understand what’s going on this functionality could just start appearing on other posts and pages…

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Polylang language switcher no longer working’ is closed to new replies.