Support » Plugin: Polylang » Polylang – Flag in header redirects to wrong page

  • On my website I installed Polylang (free version) and I use 5 languages. For every language I made a menu, connecting to pages in different languages.

    So far all good.

    Now I start at my home page (English)

    http://www.theprojectcircle.com/?page_id=147 (Permalink generated by WP)

    I click on the UK flag in header, to select the Dutch language.

    The page http://www.theprojectcircle.com/?lang=nl opens

    It doesn’t show the Dutch home page but just an un-formatted header.

    If here I click on the home button, I go to the Dutch, complete functional website with link

    http://www.theprojectcircle.com/?page_id=680&lang=nl

    How do I change my links to make it work correctly? I am aware there are other (related) topics on this issue but not understandable to me.

    Your help is really appreciated!

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Try to deactivate and activate the plugin. If this does not help, re-save permalinks.

    Thread Starter portugal2018

    (@portugal2018)

    Hi Coder,
    Many thanks for your answer. I have tried your solution but unfortunately this did not solve the issue. Do you have other suggestions?

    Deactivate all other plugins and switch to Twentyseventeen theme. Check if the error is still persist.
    If not, activate the plugins and theme one by one and figure out which plugin or theme is producing the error.

    Thread Starter portugal2018

    (@portugal2018)

    Dear Coder,
    I have deactivated all plugins as you suggested.The issue only disappears when I deactivate the Polylang plugin….
    Maybe switch to other plugin?

    I don’t believe the problem comes from Polylang. I use the plugin on a lot of sites and had never problems.
    Did you also switch the theme to twentyseventeen?
    You should run only a standard theme and Polylang plugin.
    And, make sure you have also translated the main page and the pages (EN and NL) are linked together.

    Thread Starter portugal2018

    (@portugal2018)

    Hi Coder,
    I have made some changes and got another problem…. When I try to make the home page static, I get the message “The chosen static front page must be translated in all languages.”
    I have, however, the homepage (and all other pages) available for every different language.
    As long as the home page is not static, I cannot test whether Polylang is working correctly..
    Once again, your expertise please.

    It sounds like the pages are not linked together. Did you translate them, for example, by clicking on the +-Button in the page list, on the right hand side, below the corresponding flag? Or do you create a new page from scratch and assigned only the language on the top right corn on the edit page screen?

    Thread Starter portugal2018

    (@portugal2018)

    Hi Coder,
    I have 13 pages per language, so 65 for the 5 languages. Every page at the right side of the (all pages) screen is assigned to a language (has the right check mark) and has also an order assigned.
    I did not try the twentyseventeen theme, as in the preview it messes up my complete site. The theme I am using is vGlacierVersion: 1.0.0 By Glacier Theme vGlacier Multipurpose Theme.

    If you don’t want to change the theme you will never know if the theme produces the error. Try it on a staging site. But without changing it, you will stuck with your issue.

    Thread Starter portugal2018

    (@portugal2018)

    Hi Coder,
    I followed your advice an have the twentyseventeen theme running on a staging site. Now a new problem appeared. The shortcode image_box was not found in twentyseventeen theme, so no image boxes can be displayed and the layout is really @@@@.
    Any input on how to make this image box appear in the new theme?

    This happen because the shortcode is specific to the theme.
    The goal of switching the theme is to figure out if the error is still there. If not, you know, the problem comes froim your theme and you need to talk with the theme developer or to ask somebody else to fix it, if you can’t do it.

    Thread Starter portugal2018

    (@portugal2018)

    Hi Coder,
    I understand your rationale. Unfortunately without the short-code the site is unreadable and I am not able to do any testing.

    Thread Starter portugal2018

    (@portugal2018)

    I have however found a temporary ‘dirty’ solution. No static home page but redirecting to home page using the plugin redirect.
    Maybe I will rebuild the site on a staging server but this will take some time.

    Hi @coder,
    i have the same problem of @portugal2018

    i’m working on an italian website who need to switch to english language but when i click on british flag it redirect to an another page (not the homepage)

    in the setting option i’ve checked the “force link to homepage” but it don’t work.

    I also tried to deactivated all the plugin, change theme to default wp theme but is nothing to change.

    How i can fix?
    Thank you in advance.
    Rob

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Polylang – Flag in header redirects to wrong page’ is closed to new replies.