Support » Plugin: Polylang » Polylang & Elementor – Gallery module problem

  • Hello,
    The gallery module appears only in pages with primary language but not in secondary and third language. The problem started since plugins update for WordPress 5.5

    So, is it due to:
    – WordPress 5.5 update?
    – Polylang 2.8.1?
    – Elementor 3.0.1?

    Thank you

    • This topic was modified 1 year, 11 months ago by netfly.
Viewing 10 replies - 1 through 10 (of 10 total)
  • Hello,
    I have the same issue, but I’m still on WordPress 5.4 and I don’t use Elementor. I switched back to an older version of Polylang und hope they will fix it soon.

    I have the same problem as well. If you want a quick fix, disable “media” in the Polylang settings. I use elementor and I have the problem on elementor 2 and 3.

    Reported the same issue one week ago.

    Elementor galleries missing on pages with additonal languages

    I switched back to the previous version of Polylang, too. Thanks for the quick fix, @wesleydevries95.

    Thread Starter netfly

    (@netfly)

    @wesleydevries95 Thank you VERY MUCH! I disabled Media in settings and it works fine!!

    Plugin Author Chouby

    (@chouby)

    Hello,

    Although you dont provide lot of information to allow to understand what’s happening, it seems to me that the issue is that you were exploiting a bug that we fixed in Polylang 2.8.

    Probably the media translation is activated but you did not translated the media present in the gallery.

    So you should disable the media translation if you never translate the title, caption, alternative text. Otherwise, you must translate your media and not not use media from one language in a post in another language.

    Thanks for pointing that out – and by the way, thanks for Polylang. It’s a great plugin.

    It looked like a bug because suddenly all the galleries were missing, not just the image titles.

    Found this documentation:
    https://polylang.pro/doc/working-with-media

    Cheers
    Thorsten

    @chouby
    If I deactivate the media translation, the newly uploaded images will not appear in the media gallery and will not be displayed in the articles of the main language. I also have the option to add a language to the images, but I get a white page when I try to do so.
    If I activate the media translation again, I can assign languages, but then I have to update each already uploaded image individually, or is that easier? So how do I ensure that new images work automatically for all languages?

    I also tried to add the second language but the old posts are still not showing the images because of different IDs…

    • This reply was modified 1 year, 11 months ago by basicutorials.

    Hello everybody,
    Unfortunately media are not selected in my case and the problem persists.
    I am using WPBakery and the uncode theme.

    How can i roll back to previous polylang version ?

    Disabling media translation fixed the problem. Thank you

    Hi!

    I am using Polylang for the site I created with Elementor.
    I encounter an issue that is I have saved a section under 2nd language, but I unable to open it for editing the content. When I deactivate the Polylang, the saved section can load and edit.

    I would like to know is there any solution to fix it?

    I have Polylang Connect for Elementor activated too.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Polylang & Elementor – Gallery module problem’ is closed to new replies.