Support » Plugin: Polylang » wpml-config.xml doesn’t work with custom strings for some server configurations

  • Hello !

    After many hours trying to find out why polylang wouldn’t recognize my theme strings from wpml-config.xml I realized it doesn’t work with php 7.4 .

    After downgrading from php 7.4 to php 7.3 now the wpml-config.xml gets recognized and strings are correctly shown in the strings list .

    Then I tried replicating the same configuration and changes in a different server also running php 7.3 and I was very surprised to see it doesn’t work there again !

    This one is a server running VESTACP with Nginx + Apache + MariaDB and it seems there is some kind of server configuration issue preventing polylang from working correctly there but php doesn’t seem to be the culprit since it’s the exact same version as I run on the server where polylang is now working .

    Any clues what might be wrong here ? Double checked all folder permissions and files but still seems like nothing will make it recognize wpml-config.xml in the theme folder .

    Thanks

    • This topic was modified 5 months, 1 week ago by skeepas.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter skeepas

    (@skeepas)

    No solution for this ? Tried 5 different fresh VPS installs now and wpml-config.xml is not recognized by polylang in any of them !

    No issues with the file as you can see :

    <wpml-config>
        <admin-texts>
            <key name="electro_options">
                <key name="footer_newsletter_title" />
                <key name="footer_newsletter_marketing_text" />
                <key name="footer_newsletter_signup_form" />
                <key name="site_footer_logo" />
                <key name="footer_call_us_text" />
                <key name="footer_call_us_icon" />
                <key name="footer_call_us_number" />
                <key name="footer_address_title" />
                <key name="footer_address" />
                <key name="footer_credit" />
                <key name="footer_credit_icons" />
                <key name="sidebar_margin_top" />
                <key name="header_icon_tooltip_position" />
                <key name="site_header_logo" />
                <key name="header_vertical_menu_title" />
                <key name="header_vertical_menu_icon" />
                <key name="header_departments_menu_title" />
                <key name="header_v5_departments_menu_title" />
                <key name="header_v6_departments_menu_title" />
                <key name="header_navbar_search_placeholder" />
                <key name="header_navbar_search_dropdown_text" />
                <key name="header_support_number" />
                <key name="header_support_email" />
                <key name="header_cart_icon" />
                <key name="header_user_account_icon" />
                <key name="mobile_frontpage_id" />
                <key name="handheld_header_logo" />
                <key name="handheld_footer_logo" />
                <key name="product_brand_taxonomy" />
                <key name="compare_page_id" />
                <key name="shop_jumbotron_id" />
                <key name="shop_jumbotron_bottom_id" />
                <key name="myaccount_before_login_text" />
                <key name="myaccount_before_register_text" />
                <key name="myaccount_register_benefits_title" />
                <key name="myaccount_register_benefits" />
            </key>
        </admin-texts>
    </wpml-config>
    Plugin Author Chouby

    (@chouby)

    Hello,

    Did you check that your server includes the ‘simplexml’ extension?

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.