WordPress.org

Support

Support » Plugins and Hacks » Polylang » [Resolved] Polylang and Yoast Seo

[Resolved] Polylang and Yoast Seo

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Chouby

    @chouby

    Could you activate only WordPress SEO and Polylang and use a default theme such as twenty twelve to check that the conflict is not coming from elsewhere?

    Could you precise your Polylang and permalink settings, as well as if you are using a static front page? Are you using WordPress SEO default settings or did you make changes?

    Thanks for your answer 🙂

    “Could you activate only WordPress SEO and Polylang and use a default theme such as twenty twelve to check that the conflict is not coming from elsewhere?” – I have done it and still is the same error.

    WordPress permalinks settings: http://mysite.com/%postname%/

    My home page is not a static page. My home page has two loops. Each of them list last posts for tags. When i change my home page on static page, there isn’t error. But I don’t want use a static page for home:(

    WordPress SEO: I have my settings, not default…

    …But i setting default Yoast settings and now everything is ok. Why? I don’t know…

    Plugin Author Chouby

    @chouby

    If you find which settings of WordPress SEO and Polylang conflict, then I will be very interested to know and will try to find a workaround.

    OK, I will put in one by one new settings WordPress SEO, save this and check my site. I will tell you, when it is not working. Promise 🙂

    Here is the answer:

    When I check “Redirect ugly URL links” in Yoast SEO, then i have Error 310 (net::ERR_TOO_MANY_REDIRECTS).

    That’s it 🙂 I’m stille using Yoast SEO but I disabled redirect ugly links. Now everything is OK!

    Problem is solved.

    Plugin Author Chouby

    @chouby

    Could you explain how you did solve the issue?

    Working on it, I believe that I found the reason for the conflict. WordPress SEO did not receive the homepage url in the correct language from Polylang. So I tried to solve it in the current development version. It should also solve a related issue, as the home url was not correct in the menu “SEO->Analyze this page”.
    http://downloads.wordpress.org/plugin/polylang.zip

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Polylang and Yoast Seo’ is closed to new replies.
Skip to toolbar