Support » Plugin: Polylang » Polylang always redirects to secondary Language

  • Hi everybody,

    I got a strange behaviour of the polylang plugin which keeps my going insane:

    The language of my wordpress website is german, my browser language is german. I told polylang that the default language of my website is german, the secondary language is english.

    If I enable “Recognize browser language” and keep my browser set to german, it always delivers me the english version of the site – this is so annoying and ridiculous! Caching, cookies, etc. are no issue as I kept deleting them while testing.

    This behaviour only disappears, if I disable the “Recognize browser language” feature which is not a longterm solution, as my website has to provide an english version for english browsers.

    The theme I’m using is enfold as well as an other plugin for forcing https – there are no other redirects like .htaccess cofigured. Polylang seems the be pretty well configured like out of the box.

    Why is this happening?

    Thanks for every helpful answer and best regards :)!

    • This topic was modified 1 year, 2 months ago by theotest.
    • This topic was modified 1 year, 2 months ago by theotest.
Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Polylang always redirects to secondary Language’ is closed to new replies.