Support » Plugin: Polylang » Polylang 2.2: mixes languages

  • Resolved philbee

    (@philbee)


    After updating a clients site with Polylang 2.2, the following genesis custom loop ` global $query_args;
    genesis_custom_loop( wp_parse_args( $query_args, array( ‘post_type’ => ‘post’, ‘cat’ => ‘-38,-189’, ‘posts_per_page’ => 3, ‘paged’ => 1 ) ) );
    `
    started displaying posts in mixed languages. The posts themselves are still marked “german” or “english”, and the translation links are set correctly.

    Reverting to Polylang 2.1.6 reset correct language-specific behaviour. Tested twice, on live server and on a local install. Overwriting Polylang 2.2 with current GitHub Master did not change the error.

    • This topic was modified 3 years, 2 months ago by .
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Chouby

    (@chouby)

    Hi,

    Thanks for the bug report. COuld you please check again with the development version on GitHub?

    @chouby

    Yep, “negative values in ‘cat’ query var should not exclude the language filter” did it, works perfectly again.

    Will this be in an official 2.2.1 release soon(ish)?

    Thanks!

    OMG, I had the same problem with my own website. Everything is alright in the backoffice but french posts are displayed on the English version of the website. How can I got back to the previous version, I can’t find it 🙁

    Not sure if related:

    Since the update to Polylang 2.2, I am encountering a somewhat similar issue: English and French posts are mixed.

    I installed the most recent version from Github (version of Aug 28, 2017, commit c05ae17), but it did’t fix the problem.

    I am using a special template with custom queries that make use of the “lang” parameter. This was working fine, and was necessary, as without the “lang” parameter the query wouldn’t get the language context.

    The behavior now seems to be the opposite: when the “lang” parameter is present, whatever the value, it always returns a mixture of languages.

    What works: when I remove the “lang” parameter, the query returns the expected result. It is aware of the language context and shows only the relevant posts.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Polylang 2.2: mixes languages’ is closed to new replies.