WordPress.org

Support

Support » Plugins and Hacks » [poll id="2" type="result"] works, [poll id="2"] doesn't?

[poll id="2" type="result"] works, [poll id="2"] doesn't?

  • To be fair, so far I’ve only tested this in post preview, because I don’t want to publish an entry yet. But on post preview, the former displays just fine, but the latter calls up the error text that there aren’t any polls available.

    Any ideas? Is this just some sort of strange bug that prohibits the poll from being displayed during post preview unless using the results argument in the shortcode?

    Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Lester Chan

    @gamerz

    Does it appear after you posted it?

    I don’t know yet. I was hoping someone else had encountered the issue and could tell me if it worked for them, so I don’t have to confuse my blog readers by posting either a test post or a broken one.

    It definitely does the same thing even if published. And unlike this older thread (which I only just saw), I’m not using any caching.

    D’oh. Never mind. It was reacting to a WP-Polls setting (“Current Active Poll”) that I thought was only applicable to sidebar usage. Changed that setting and now it works.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[poll id="2" type="result"] works, [poll id="2"] doesn't?’ is closed to new replies.