WordPress.org

Forums

myCRED
Points get added to all users? (14 posts)

  1. bffnb
    Member
    Posted 1 year ago #

    Hi!

    I used your plugin to give users on my site points for posts, comments and so on. I loged out logged in with a test user and ad a post - the points get added to my admin user as well to my other (second) user and if i use the admin user account the points added to the other users to?

    I user a fresh wp 3.7.1 Multisite installation...

    Any idea? Or is this normal, because i have the same IP or...?

    Best

    http://wordpress.org/plugins/mycred/

  2. Gabriel
    Member
    Plugin Author

    Posted 1 year ago #

    Hey bffnb.

    Please check your "Points for Comments" hook on your myCRED > Hooks page where you must set how many points the comment author gets AND how many (if any) points a the content author gets.

    myCRED supports points to be awarded both to the commenter AND the content author (i.e. get points for users commenting on your post).

  3. bffnb
    Member
    Posted 1 year ago #

    Hi!

    Here my settings

    http://pizzeriainnsbruck.at/wp-content/uploads/XXXXX/123.png

    All other settings be default - i changed nothing.
    I created the user my self with the admin account to test the plugin - but unfortenetly all users gett alwys the same pints added??

    I used this code to show the count of each user in my template - maybe there is the error:

    <?php echo do_shortcode('[mycred_my_balance]'); ?>

    In the log og the Plugin it shows the right number..

    Thank you so much

  4. Gabriel
    Member
    Plugin Author

    Posted 1 year ago #

    Hey.

    So when you visit the myCRED > Hooks page, all icons are red even if they have been enabled (as shown in the screenshot)?

    Please enable WP_DEBUG in your wp-config.php file and see what error messages you get. This will allow you to see if there is anything wrong.

    Note! By enabling WP_DEBUG you will show ALL error messages, not just myCRED's but also errors from other plugins and your theme.

  5. bffnb
    Member
    Posted 1 year ago #

    Hi!

    Yes, all the icons are red even some are enabled. Here the result form the Debug Mode:

    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /var/www/vhosts/mytestsite.de/httpdocs/wp-includes/functions.php on line 2919 Notice: Undefined index: pmjsscript in /var/www/vhosts/mytestsite.de/httpdocs/new/plugins/cartpauj-pm/pm-class.php on line 91 Notice: Undefined index: settings-updated in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/options.php on line 22 Notice: Undefined index: settings-updated in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/options.php on line 36 Notice: Undefined variable: force_reauth in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/functions.php on line 175
    
    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /var/www/vhosts/mytestsite.de/httpdocs/wp-includes/functions.php on line 2919 Notice: Undefined index: pmjsscript in /var/www/vhosts/mytestsite.de/httpdocs/new/plugins/cartpauj-pm/pm-class.php on line 91 Notice: Undefined index: settings-updated in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/options.php on line 22 Notice: Undefined index: settings-updated in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/options.php on line 36 Notice: Undefined variable: force_reauth in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/functions.php on line 175 
    
    Notice: Undefined index: view in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/author.php on line 183 Notice: Undefined index: view in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/author.php on line 187 Notice: Undefined index: view in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/author.php on line 214 Notice: Undefined index: view in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/author.php on line 214 
    
    Notice: Undefined index: pnum in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/author.php on line 298
    
    Notice: Undefined property: WP_Query::$ID in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/author.php on line 338 Notice: Undefined property: WP_Query::$ID in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/author.php on line 342 Notice: Undefined property: WP_Query::$ID in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/author.php on line 342 Notice: Undefined property: WP_Query::$ID in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/author.php on line 342 Notice: Undefined property: WP_Query::$ID in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/author.php on line 342 
    
    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /var/www/vhosts/mytestsite.de/httpdocs/wp-includes/functions.php on line 2919 Notice: Undefined index: pmjsscript in /var/www/vhosts/mytestsite.de/httpdocs/new/plugins/cartpauj-pm/pm-class.php on line 91 Notice: Undefined index: settings-updated in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/options.php on line 22 Notice: Undefined index: settings-updated in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/options.php on line 36 Notice: Undefined variable: force_reauth in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/functions.php on line 175 Notice: Undefined variable: force_reauth in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/functions.php on line 175 Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /var/www/vhosts/mytestsite.de/httpdocs/wp-includes/functions.php on line 3017 Notice: Undefined variable: force_reauth in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/functions.php on line 175 Notice: Undefined variable: force_reauth in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/functions.php on line 175 
    
    Notice: Undefined variable: force_reauth in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/functions.php on line 175 Notice: Undefined variable: force_reauth in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/functions.php on line 175 
    
    Notice: Undefined variable: force_reauth in /var/www/vhosts/mytestsite.de/httpdocs/new/themes/mytesttheme/functions.php on line 175

    Note again, the points get always added to all users or when i log in with admin or user - the other users have always the same points as the user im useing at the moment ?

    One other note - i dont use WP-CONTENT i canged the name and
    use in wp config
    define('WP_CONTENT_DIR', $_SERVER['DOCUMENT_ROOT'] . '/new');
    define('WP_CONTENT_URL', 'http://mytestsite.de/new');

    Note: i only changed some letters to hide my site before i post this here ;)

    best

  6. Gabriel
    Member
    Plugin Author

    Posted 1 year ago #

    I would need to setup a test environment where I could test your wp content setup and see if that is the issue as none of your posted error messages are myCRED related.

    Could you tell me about your setup? You say you use multisite, is myCRED network enabled or only enabled on a single site? Also, how many hooks do you get? How about add-ons? Same issue there?

  7. bffnb
    Member
    Posted 1 year ago #

    Hi!

    The Plugin is only enabled for the mainsite. In the Plugin settings i only changed points to punkte (german) and use the sttings metnioned before:

    http://pizzeriainnsbruck.at/wp-content/uploads/XXXXX/123.png

    no addons avitvated.

    Again - is this code ok:
    <?php echo do_shortcode('[mycred_my_balance]'); ?>

    It always shows the point of the logged in user for all the other user. my admin account has 9 points, a new user has 0, but when i click on the users page where the shortcode is implemented it always shows the point of the admin (the current logged in user) - When i log out and use the new user with 0 points - and then show to the profile page of the admin, it shows me again the 0 - the points of the actual logged in user?

    best

  8. Gabriel
    Member
    Plugin Author

    Posted 1 year ago #

    Of course it does, the mycred_my_balance (as the name suggests) shows your balance, you as the currently logged in user. I think you are looking for the mycred_get_users_fcred function which shows a given users balance.

    You can find usage examples in the myCRED documentation.

  9. bffnb
    Member
    Posted 1 year ago #

    Thx i understand, but it does not work on my site....?

    Please let me know if you have any idea.

    thx

  10. Gabriel
    Member
    Plugin Author

    Posted 1 year ago #

    If you are using a fresh WordPress installation without any other plugins active and using one of the default themes and still have the same issue you have with the hooks, your issue is the wp-content folder modifications you made.

  11. bffnb
    Member
    Posted 1 year ago #

    Hi!

    I understand - but you must know how the plugin is calling the functions regarding the wp-Content folder. If you run a website to test your plugins - it would be easier to change temporarily the wp.content folder name with this two lines in the wp-config and change the folder name as a new wp-installation. Would be great if you can do that for me :)

    Thank you so much
    best

  12. Gabriel
    Member
    Plugin Author

    Posted 1 year ago #

    Hey bffnb

    Sorry for the delay in my reply. I have setup a test site with the customizations you showed and can not replicate the issue. What is your PHP version just in case?

  13. bffnb
    Member
    Posted 1 year ago #

    Hi!

    My VERSION is 5.4

    best

  14. Gabriel
    Member
    Plugin Author

    Posted 1 year ago #

    I am still not able to replicate this issue.

    Looking at the screenshot you provided, I can draw the following conclusion:
    - The accordion script is not getting loaded or collides with some other third-party script.

    I would try and disable one plugin at the time and see when the accordion starts working on the hooks page or your add-ons page. Some third party plugins will insert scripts on all admin pages and not just on the relevant page which has in the past shown to brake things.

    Using the latest WP and myCRED I can not replicate this issue so at this stage I would eliminate all other plugins to see if that works.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.