Poedit fatal error, can't generate the .mo file?! (5 posts)

  1. Fking
    Posted 5 years ago #

    I’m translating an English pot file to Bulgarian (Cyrillic) using Poedit

    When tried to save I got:
    11:49:52: D: \New Folder\languages\111.po:813: missing `msgstr[]' section
    11:49:52: msgfmt: found 1 fatal error

    As a result the .po file wasn’t generated, just the .mo, so I can’t use the translation now.

    Is there a way around that?

  2. Fking
    Posted 5 years ago #

    or maybe other software? anyone?

  3. esmi
    Forum Moderator
    Posted 5 years ago #

    This is an issue between PoEdit and WordPress. PoEdit seems incapable of dealing with the _x plurals. I've not tried any of the tools listed below but perhaps one of these will help:

    In the meantime, I'll try and find out what .po editor is being used in the plugins SVN repository. That copes with all of the localization strings without any problem.

  4. Fking
    Posted 5 years ago #

    thanks for that!
    I managed to make it work with this fix:

    enter this in the Plural forms field in Catalog>Settings
    nplurals=2; plural=(n != 1);

  5. esmi
    Forum Moderator
    Posted 5 years ago #

    I'm told that this fix either doesn't work or isn't reliable enough to be used by plugin developers (more's the pity). But if it works for translators, great! :-)

Topic Closed

This topic has been closed to new replies.

About this Topic