Support » Plugin: Pods - Custom Content Types and Fields » Pods sidebar menu broken when CMS plugin deactivated

  • Resolved archlucs

    (@archlucs)


    Hello guys, I’m sorry if I can’t give you a proper context of my problem but I’m new to WP in general. I’m here because I have a huge problem which I’m not even sure it’s related to the Pods plugin:
    When I deactivate the “Role Scoper” plugin the sidebar menu listing my Pods items gets broken, for instance, the buttons “Add New” “All NameOfThePod” disappear. This plugin tries to implement a sort of CMS inside WP (I believe), it adds some functionality to roles and capabilities. I tried to search/edit every option I could find with no luck so far. Here are some screenshots:

    Before: https://imgur.com/a/VLP3zjc
    After: https://imgur.com/a/lrBqYRq

    I know the 4 tables that the plugin creates as well as the rows that it adds to the WP options table because they have a prefix.

    If anyone has an idea to what to try or how to handle this situation. Please help me.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Jim True

    (@jimtrue)

    Sounds like you need to escalate to Role Scoper; that’s a conflict. If it’s doing some kind of overwrite of the Roles & Capabilities, etc. that’s your issue. You should escalate to that plugin author/developer/support as it’s obviously stepping over your access rights.

    I resolved it by tweaking the Roles and Capabilities “Module” of your plugin after disabling the Role Scoper plugin. It seems like there were “shared information” that weren’t properly cleaned/set. Anyway, I resolved it! Thanks for your reply. Luca

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Pods sidebar menu broken when CMS plugin deactivated’ is closed to new replies.