Support » Plugin: Pods - Custom Content Types and Fields » Pods Relationship not appearing after moving host

  • Resolved melisa.ciputra

    (@melisaciputra)


    Hi guys,

    My pod’s input with field type: relationship are not appearing after moving host. The pods worked fine in the old hosting site. The error I got is: Failed to load resource: the server responded with a status of 500 ()

    I matched my plugins to my old hosts so there’s no plugin conflicts. I suspect this is server issue but not sure what to tell the hosting support guy. Has anyone else experience this? Any idea?

    Thank you in advance.
    Cheers, Mel.

    Debug Information
    WordPress Version: 5.1

    PHP Version: 7.1.26

    MySQL Version: 5.6.36

    Server Software: Apache/2.4.29 (Unix) mod_hive/6.25 OpenSSL/1.0.1e-fips mod_fastcgi/2.4.6

    Your User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.119 Safari/537.36

    Session Save Path: /tmp

    Session Save Path Exists: Yes

    Session Save Path Writeable: Yes

    Session Max Lifetime: 1440

    Opcode Cache:

    Apc: No
    Memcached: No
    OPcache: Yes
    Redis: No
    Object Cache:

    APC: No
    APCu: No
    Memcache: No
    Memcached: Yes
    Redis: No
    WPDB Prefix: wrd_

    WP Multisite Mode: No

    WP Memory Limit: 40M

    Current Memory Usage: 21.009M

    Current Memory Usage (real): 22.000M

    Pods Network-Wide Activated: No

    Pods Install Location: /home/wellnour/public_html/wp-content/plugins/pods/

    Pods Tableless Mode Activated: No

    Pods Light Mode Activated: No

    Currently Active Theme: Well Nourished

    Currently Active Plugins:

    AffiliateWP: 2.2.7
    Akismet Anti-Spam: 4.1.1
    AppPresser: 3.7.1
    Better WooCommerce Stars Shortcode: 1.0
    Boxzilla: 3.2.10
    Classic Editor: 1.4
    Custom Product Tabs for WooCommerce: 1.6.9
    Custom Thank You Pages Per Product for WooCommerce: 1.4.0
    Dagon Design Sitemap Generator: 3.17
    Genesis Connect for WooCommerce: 1.0
    Google Analytics for WordPress by MonsterInsights: 7.4.2
    Instagram Slider Widget: 1.4.3
    jQuery Pin It Button for Images: 3.0.4
    Mailchimp for WordPress: 4.4
    Page scroll to id: 1.6.4
    PixelYourSite: 7.0.0
    Pods – Custom Content Types and Fields: 2.7.12
    Really Simple SSL: 3.1.4
    Sassy Social Share: 3.2.17
    SG Optimizer: 5.1.1
    ShortPixel Image Optimizer: 4.12.8
    Simple Basic Contact Form: 20181212
    Sub Categories Widget: 1.5.1
    UpdraftPlus – Backup/Restore: 2.14.11.1
    WooCommerce: 3.5.5
    WooCommerce Product Bundles: 5.7.11
    WooCommerce Product Feed: 3.0.5
    Wordfence Security: 7.2.3
    WordPress Popular Posts: 4.2.2
    WordPress Related Posts: 3.6.4
    WP-Optimize: 2.2.12
    WP Recipe Maker: 4.3.3
    WP Recipe Maker Premium: 4.2.1
    Yoast SEO: 9.7

Viewing 15 replies - 1 through 15 (of 15 total)
  • Another thing, the new host is Siteground. I have turned off memcache and even deactivate the entire SG Optimizer and purge caching after but no luck. Increased the memory but also no luck.

    Plugin Author Jim True

    (@jimtrue)

    How did you perform the migration?

    Also, did you go into Pods Admin, Settings, Clear Cache?

    Hi Jim, thanks for your reply. Siteground did the migration for us so I’m not sure how they did it (using CPANEL maybe). I’ve cleared the pods cache multiple times already.
    Increasing PHP and WP memory did not help either. I created new pods and RELATIONSHIP field type is still not appearing with same error. Does relationship field type require special resources?

    I’ve talked to Siteground and they were baffled too.

    Any idea? Thanks again.

    Plugin Author Jim True

    (@jimtrue)

    Siteground should have more information in their server logs. The 500 should actually be pointing to something specific. There is one table that is required for relationships wp_podsrel but you’d be getting very specific SQL errors if it didn’t exist or had permission errors, or it should.

    Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    The cPanel -> Error Log tool plus the php_error.log should provide detailed information.

    Plugin Author Jim True

    (@jimtrue)

    Thanks @hristo-sg 🙂

    Thanks Jim and Hristo for your input.

    So we could not see anything wrong in the error log. Perhaps because the error only shown in the browser inspect?

    Anyway, The Siteground Support guy managed to solve this issue by changing the website’s PHP version from 7.0 to 5.6 somehow? This is weird because our previous host was at PHP version 7.0.

    Any idea how moving PHP version back fix it? I am worried about sacrificing PHP version since it’s old.

    Thanks again guys.

    Plugin Author Jim True

    (@jimtrue)

    You said the error was only showing in the browser: like a JavaScript conflict?

    The error only seen on browser inspect as shown here https://imgur.com/Q2rBAd8
    This is when the relationship not showing: https://imgur.com/YW47F05
    This is what it’s meant to look like and after it’s fixed https://imgur.com/a/qsiqxqz

    Thanks Jim

    Plugin Author Jim True

    (@jimtrue)

    It’s definitely not loading the relationship field at all in that situation which would normally indicate a JavaScript conflict. But if the server is responding with a response of 500, it’s got to be providing more details at the server level. You said you had the issue under PHP 7.0, what about a higher level of PHP?

    Hi Jim,

    Sorry I just checked the Debug Information above and was mistakenly said PHP 7.0. The error happened when PHP was PHP 7.1. The Support guy fixed it by changing it to PHP 5.6.
    I just tried 7.2 and 7.3 but they came back with same error.
    I tried PHP 7.0 and the error was not there! So basically the error starts showing when it’s PHP 7.1 and above.
    I will settle with PHP 7.0 and close this issue.

    Thank you so much for your help Jim. I would not have tried other PHP versions if you did not suggest them.

    Plugin Author Jim True

    (@jimtrue)

    I’m a little worried by the newer php versions causing the issue, so I’m still having Scott look this one over. We might reach out to you for some more information if that’s okay.

    Sure Jim. I’ll be happy to help.

    Plugin Author Scott Kingsley Clark

    (@sc0ttkclark)

    Melisa, do you have access to a site / staging environment that still has this issue happening?

    Hi Scott, yes I still have access to the clients site.

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.