Support » Plugin: Pods - Custom Content Types and Fields » Pods CPT stop displaying

  • Resolved MorgunovVit

    (@morgunovvit)


    Recently, I’ve noticed that my Pods posts don’t display anymore.
    What happened – there’s no errors in chrome DevTool console.
    It worked fine before.
    The grid displays Pods post cards well: https://mc21academy.ru/katalog-programm/
    But page with Pods post template – empty.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi! It seems, that I’ve fixed the problem. I’ve just restored the template php file.
    Sorry for disturbing!

    Plugin Author Jim True

    (@jimtrue)

    No worries, did you compare the two to see what the difference was or was it just gone?

    Hi. In some reason I forgot, that in my theme (Social Learning Boss theme), PODS CPT (named learning-program) works only with program-content.php theme template.
    This template is responsible for displaying the content of pages and archived pages. Carelessly I renamed this template and PODS stopped working. Unfortunately I don’t remember, why it doesn’t enough PODS template (named Program-single). And why it works only with php theme template with this name. In my other themes everything works without PHP templates only with PODS teplate.

    Plugin Author Jim True

    (@jimtrue)

    Might be something inside your functions.php, but yes, typically single-<post-type>.php is the proper way to name those.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Pods CPT stop displaying’ is closed to new replies.