Support » Plugins » Pods – cannot update custom term titles

  • Resolved erikshosting

    (@erikshosting)


    I’m having an issue editing old custom term titles (created using Pods). Basically I cannot update an existing term title when the term has any sort of custom fields added to it via pods. I can still add new terms, but after they are created I cannot edit their titles anymore.

    When I edit a term title it comes back as item saved, but I’m getting a 302 error in console from edit-tags.php.

    If I comment out the wp_redirect on line 168 of wp-admin/edit-tags.php and try editing a term title, I get a white page with a 200 response but checking the db the term title did not update.

    I’ve found that if I remove all of the custom fields from the custom term via the pods panel, I I can edit the term titles again. I have a few custom fields added to the term, and it doesnt matter which ones I remove the term title can only be updated/saved when all of the custom fields are deleted from it. Basically if I have any custom fields added to that term then I cannot update the title. I’ve tried removing all of the terms and adding a single simple custom field to the term and this stops the terms title from updating, so I havn’t been able to pin down what about the custom field breaks it..

    I’ve turned on wp debug and I’m not getting any errors. I’ve got all plugins other than Pods disabled. I’ve tried repairing and optimizing the database via phpmyadmin. I’ve also tried connecting the install to a new database and importing the old db into it. I’ve also tried the pods reset then used the pods import to pull in my old pod settings. None of these have worked.

    I have pods installed. With a custom post type of ‘samples’ added and a custom term of ‘voices’ added to that post type. I have several text block, single line of text, and relational fields added to the term ‘voices’. When I remove all of the fields added to the term ‘voices’ I can edit the titles of existing terms again. If there are any fields added to the term, the title doesnt update on save. I have table type storage and relational fields pods components activated. Removing the relational field from the term does not fix. only removing all fields fixes the update process.

    Well, I hope that’s detailed enough. I’d love to get this working again, pods really is my favorite wordpress plugin
    -Erik

Viewing 9 replies - 1 through 9 (of 9 total)
  • What version of Pods are you using?

    Version 2.4.3

    What i’ve found tracking the post request to the sql run, that the wp_update_term function is firing twice, the first time with the params from the tag edit form, the second time with the same args as it retrieved from the db before doing the update which reverts the change.

    What I’ve found so far is that it’s something firing on the ‘edit_term’ action hook that is firing wp_update_term a second time with the old params, reverting the change. When I take a look at all of the actions attached there, I see this:

    array(0) { } array(1) { [10]=> array(1) { ["00000000517feef4000000000d0389acsave_taxonomy"]=> array(2) { ["function"]=> array(2) { [0]=> object(PodsMeta)#262 (1) { ["api":"PodsMeta":private]=> NULL } [1]=> string(13) "save_taxonomy" } ["accepted_args"]=> int(3) } } }

    and that’s about where I’m at now..

    inside of the pods PodsMeta->save_taxonomy method, on line # 1476 $pods->save is being called on param $data which contains the old data (or at least just the term title that I’ve been testing against) called from the db before the the whole save process started, rather than the data submitted on the edit-tags forms post action

    Can you try Pods 2.5 beta? http://pods.io/latest/

    I appreciate the quick response and your replies to my thread. Thanks for all the hard work on pods, it’s a wicked plugin. I use it on almost everybuild.

    alright, I’ve got 2.5 beta1 loaded in now but it keeps giving me memory size exhausted errors from podsAPI.php on line 7930. I’m running at a size of 268435456 bytes which is pretty high already, something like ~260mb.

    ..but it is definitely saving the name field to the db and not reverting it anymore! awesome!

    You may want to go to Pods Admin > Settings > Clear Pods Cache

    That could help on the memory issue you’re seeing.

    Awesome, that sorted it out. I also saw the new update to pods got pushed to production so I’ve loaded that in, everything is working great. Good stuff. I really appreciate all the help, thanks again.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Pods – cannot update custom term titles’ is closed to new replies.