Support » Plugin: Pods - Custom Content Types and Fields » Pods breakage due to new PHP/MySQL requirements

  • Resolved steevithak

    (@steevithak)


    Our PODS based site is not working due to an unexpected change in PODS PHP and MySQL version requirements in the latest plugin update. Is there any way to revert the PODS plugin to the previous version in the short term while we investigate the possibility of PHP/MySQL updates?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter steevithak

    (@steevithak)

    Looks like our MySQL is up to date. We’re running an Enterprise Grade distro, CentOS 6.9, and the provided MySQL is 5.1.73-8, which includes back ports of all the latest MySQL security updates. Can you clarify what Pods is doing that’s not compatible with this version? For security reasons, we’d prefer not to run an unsupported version of MySQL.

    Plugin Author Jim True

    (@jimtrue)

    As a temporary stopgap, you can add the following to your wp-config.php to allow a lower version of MySQL:

    define( 'PODS_MYSQL_VERSION_MINIMUM', '5.0' );

    It’s a workaround and it should still work, but we recommend you get updated to 5.6+ or above (even WP as a project recommends 5.6+ because all other MySQL versions are EOL for support).

    Thread Starter steevithak

    (@steevithak)

    Thanks, I’ll give that a try! RedHat will continue to provide support for the RHEL and CentOS official MySQL versions until the respective RHEL/CentOS distros go EOL. And they will continue to back port all MySQL security patches and test for binary compatibility, so it’s safer for RHEL/CentOS users to stick with the official version until moving to CentOS 7.x in a few years. Installing a MySQL from an unsupported repo or, worse, installing a homemade version built from source, can create security issues. According to the WordPress site MySQL 5.6 is “recommended” but 5.1 is still fully supported by WordPress. WordPress usually follows the version supported by the Enterprise grade GNU/Linux distros, so we’ll look at moving when they change their requirements.

    Plugin Author Scott Kingsley Clark

    (@sc0ttkclark)

    Going to set our minimum to 5.1 in our bug fix release out tomorrow, based on that information. Thanks for the heads up!

    https://github.com/pods-framework/pods/pull/4634

    Thread Starter steevithak

    (@steevithak)

    Thanks! 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Pods breakage due to new PHP/MySQL requirements’ is closed to new replies.