WordPress.org

Support

Support » Plugins and Hacks » Podpress won't work on single posts.

Podpress won't work on single posts.

  • johngorenfeld
    Member

    @johngorenfeld

    I’ve installed Podpress and it works great–except on single post views. Instead of the Flash player, I get the [display_podcast] code, not replaced as it should.

    Any ideas for how to work around this? Maybe the answer is to auto-insert the Podpress code at the beginning somehow, without having to type [display_podcast]? If so how?

    Any help much appreciated.

Viewing 15 replies - 1 through 15 (of 38 total)
  • There is an option at the general settings page of podPress which you can use to display the podPress row above a post content.

    I have tested this now in my demo blog and I can say that this problem happens not everywhere. The player appears at the position in the post where I have inserted the [display_podcast] short code – on the main blog page as well as in the single post view.

    So it is eventually a problem which occurs only with certain settings combination. Could you tell me your Post Content settings from the general settings page?

    It could be another plugin which is also adding something to the post content, too. Although … If it is another plugin, it is interesting that the problems seems to be only in the single post view.
    Did you have the possibility to deactivate such plugins temporarily to find out if there is an interference?

    Regards,
    Tim

    Which version of podPress do you use? 8.8.5 RC?

    johngorenfeld
    Member

    @johngorenfeld

    Thanks for the help. I hope this post shows up, by the way–I keep receiving error messages from WordPress.org telling me the topic has been “closed.”

    I’m using WordPress 3.0 with the Thesis theme, which perhaps is the cause of the problem. I’m using podPress 8.8.5 and have tried the latest stable version, the experimental and the development versions, with the same result.

    About the General Options choice that inserts the file above the post: I tried this last night after posting this question. What happened was similar. The main index page showed the Flash player, but the single post view showed nothing.

    johngorenfeld
    Member

    @johngorenfeld

    p.s. I’ve tried deactivating other plugins to see if there is a conflict, but no luck.

    johngorenfeld
    Member

    @johngorenfeld

    Location: Start
    Image: Button
    Player: Enabled
    Download: Enabled
    Show Download Text: Enabled
    Show Download Stats: Disabled
    Show Duration: Enabled
    Before <!– More –> Tag: Yes

    John, as you can see in this test post, the problem you have described above exists not in my demo blog. That leads me to the conclusion that there are certain circumstances in your blog which are causing this problem.
    If we could find the cause and if it is somewhere in podPress then I could write a patch and fix it.

    Please, tell me your Post Content settings from the general settings page of podPress.

    Location: Start | End ?
    Image: Button | Icon | None ?
    Player: Enabled | Inline only | Popup only | Disabled ?
    Download: Enabled | Disabled ?
    Show Download Text: Enabled | Disabled ?
    Show Download Stats: Enabled | Disabled ?
    Show Duration: Enabled | Disabled ?
    Before <!- More -> tag: Yes | No ?

    Can you tell me if there are Javascript errors during the loding process of the single post view? (For instance the Firefox browser has something in the menus that is called error console. Open it, clear the old messages if there some, then reload the single view of a post and it will show you eventually error messages. Other browsers do have something comparable.)

    p.s.: I have nothing to do with status of this thread and I don’t know why you are getting these “closed”-messages.

    johngorenfeld
    Member

    @johngorenfeld

    Thanks, I really appreciate it and didn’t mean to blame you for the thread status–it’s just that WordPress.org was behaving oddly.

    OK, so the General settings are in my previous post. I checked the Error Console and I’m getting

    “Unknown property ‘transition.’ Declaration dropped.”

    “Unknown property ‘-moz-opacity.’ Declaration dropped.”

    But these are just validation, right? Here’s the problematic page and the main page where it works right:

    Shahid Buttar: Fix Patriot Act; Dahr Jamail: Unembedded on the BP Gulf

    http://www.peterbcollins.com

    Shahid Buttar: Fix Patriot Act; Dahr Jamail: Unembedded on the BP Gulf

    Have you written the post with your Post Content settings before or after my last post?

    I have discovered it just now. I would say it was not there some hours ago.

    These settings seem not to be the cause for the problem.

    But thank you for the link to your page!
    There is on big difference between the appearance of your posts at your main blog page and the single post view pages: at the end of the single post views (at least of the last posts 4-5 posts) is a YouTube video which is not visible at the main blog page.
    This YouTube video is probably inserted by plugin. Am I right?
    If it is inserted by plugin then please, make a short test, deactivate it temporarily and look if [display_podcast] short code is going to be replaced correctly. What is the name of this other plugin?
    If it is not inserted by plugin then how you insert these videos?

    johngorenfeld
    Member

    @johngorenfeld

    Hi ntm,

    I wrote the post a while back. But even after I wrote it, WordPress.org was claiming that you had the most recent post. So I think there might be a bug where it’s not showing up for you.

    The YouTube video is something I added last night at the client’s request. It’s not part of the content logic. Instead it is just a static insert on the index view. (In Thesis, changes to the theme are done using “hooks” at certain entry points in the code.) Anyway, the YouTube video isn’t the cause of the Podpress issue, which predates it.

    Thanks for continuing to look at this.

    Hm, okay if the problem was there before you have added the video then the way you are adding the video is not the cause.

    I have tried to test a little bit with the Thesis Theme but it seems that it is only available if you pay for it.
    I have searched with Google for the [display_podcast] short code and “diythemes” and I found several sites with this theme and the [display_podcast] code somewhere in the content of the posts.
    I found one site where the podPress plugin is active and has this problem, too.

    It has eventually something to do with the theme.
    Please, use the theme preview at the Appearance > Themes page in this Peter Collins blog and check if the player appears in the preview of the single post view of the default theme (Kubrick or Twenty Ten).

    johngorenfeld
    Member

    @johngorenfeld

    Good idea, I’m going to try that.

    johngorenfeld
    Member

    @johngorenfeld

    Yup. It’s Thesis and it’s breaking it.

    Can you tell what Thesis does different than the other theme(s)?

    podPress uses the action hook “the_content” to insert the necessary lines of code into the posts (podpress.php line 841 and the function is in the file podpress_class.php line 763)

    Furthermore it uses the filters “get_the_excerpt” and “the_excerpt” to do the same with excerpts. But I found out that there is probably a bug in podPress. In the lines 842 and 843 of the podpress.php these filter hooks are called as they would be action hooks (e.g. add_action('the_excerpt', array(&$podPress, 'insert_the_excerptplayer')); instead of add_filter('the_excerpt', array(&$podPress, 'insert_the_excerptplayer')); ).

    It seems to me that the problem could be somehow connected with what’s happening in the functions insert_content(), insert_the_excerptplayer() or insert_the_excerpt().

    johngorenfeld
    Member

    @johngorenfeld

    I don’t know it well enough to say. It automates a lot of stuff and does not use the typical page.php, sidebar.php, etc. layout.

    So maybe I’ll try to slip that other language into the podpress.php file and that might fix it?

Viewing 15 replies - 1 through 15 (of 38 total)
  • The topic ‘Podpress won't work on single posts.’ is closed to new replies.