Support » Fixing WordPress » Podpress won't produce iTunes feed correctly

  • I cannot get PodPress to produce a feed that iTunes will accept. I suspect this is because of changes I made to the URL structure of my WP-powered site between the time when I installed PodPress under a temporary URL structure and when I changed the URL structure (‘pointed’ my new domain’s DNS to resolve to the folder of my temporary URL). We all do this– set up a new domain as a secondary domain on a hosting account. Simple.

    Now, I figured uninstalling PodPress might remedy the situation. Nope. In fact, uninstalling and re-installing PodPress produces a “new” PodPress installation that preserves all my settings?! Hu?

    Again, I installed PodPress and set it up **while preparing my site to go live on it’s own URL**. Meaning I have my PodPress/WP instal running as a secondary domain on (and inside a folder of) an existing URL/hosting account. So the URL structure that PodPress “got friendly with” was Eventually (when I set my DNS and turned the site live to public) the URL changed to What seems to have happened is that PodPress is now in love with–unable to divorce itself from–my WP installation (even after deleting it), my settings and my old URL structure. Neat hu? This is producing feeds with links that are dead links.

    Now that my domain structure has changed PodPress needs to change too. But it won’t.

    Everything with PodPress worked just fine when I set it up under the temporary domain structure. The problem here is the contents of the feed that is outputs: It still contains URL structures that look like this: (which are now dead links)

    My site is putting out this feed which *I think* is being powered by PodPress

    Although PodPress is telling me in Feed Podcast settings that it’s putting out this feed:

    current Feed URL

    … again, using “Feed Podcast” option that is activated and set to output my Podcast category (that I set using the Filter function).

    As you can see, that PodPress-created feed is actually dead. Zippo.

    Wait. It gets even more screwy! I can see in the XML contents of the feed that PodPress is at work on my feed… creating it and inserting my iTunes data. Great! But we can also see that it’s got all kinds of references to… (the old site URL structure!)… which, of course, iTunes rejects.

    Now if you’re still reading THANK YOU. Because I’ve been at this all day and am at wit’s end. Can anyone offer help? Many, many thanks for considering.


Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi Jeff,
    is actually a RSS feed which is produced by WP and is a standard category feed – in this case of the category with the slug name “podcasts
    You may customize this feed via Site Admin > Posts > Categories > Edit Category ( On this page you can find a section podPress Category Casting which will offer option similar to the ones on the Feed/iTunes Settings page of podPress.
    is a RSS or ATOM feed which will work only while podPress is active. This is a feed which additional to your blog. It contains by default only posts with a podPress attachment independently of the category of a post. It may contain posts of different categgories. But you may use the Category Filter option to regulate this.

    But we can also see that it’s got all kinds of references to… (the old site URL structure!)… which, of course, iTunes rejects.

    I can see the old URLs only the <guid> values of the posts (<items>). This is not okay but it should bother iTunes. Because this is as the tag name “guid” says, it is a globally unique identifier for the XML item. It may be the URL to the post but necessarily. It should be a unique string which helps to identify the XML item. You may read more about this tag here:
    You may also read the description of this element here:
    These <guid> values are not the link to the post nor to the media file. It is mostly an indicate which helps the feed reader software to determin whether a post (or episode) is new.

    Furthermore these values are usually generated by WP.


    Many, many thanks. Without your help I’d be totally lost. Based on your description (of this being a WP thing ultimately) I think I fixed it! I simply deleted the posts and re-posted them. Now, upon checking, the Podpress-generated feed seems to NOT contain the offensive links.

    The only mystery that remains is why, now, the Podpress player and download link do NOT appear in the actual post. You CAN see them appearing here BUT not in individual posts. I’ve checked all settings, re-saved settings, etc. to make sure I’m not missing anything. Have you any idea why the player might not be appearing?

    Thanks so much, Tim.

    Whoops! My bad, Tim. Sorry. Player IS appearing. It’s just appearing too far down the page. I’m not sure how to fix that but it looks like a template issue.

    It’s just appearing too far down the page.

    It seems to me that you found a way around this issue. I guess that you are using the [display_podcast] place-holder. Right?
    However this is a CSS issue which depends on the rest of the CSS of your theme. If the position is wrong you may alter it e.g. by defining new style information for the main <div>-element of podPress which has the class podPress_content and a second class name depending on the media file e.g. podPress_content_audio_mp3.

    If you point me a little bit more to the problem, I may be able to help you with the CSS modifications.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Podpress won't produce iTunes feed correctly’ is closed to new replies.