Support » Fixing WordPress » PodPress stopped tracking iTunes correctly?

  • Resolved gamebynight


    Hi Everyone,

    I’ve been putting on a podcast since November using PodPress to keep track of my stats. Since then, the majority of our downloads have been reported under the “feed” section of the PodPress stats table. Within the last few episodes, however, the amount of iTunes downloads has drastically dropped compared to how much bandwidth each file is using. Our server stats show that listenership has been going up (episode 9, the last one, especially) except podpress is saying that it only got 14 downloads, three of which were test plays for a few seconds.

    The main difference is that over the last three episodes, we went from 168 iTunes downloads, to 6, to 2. I’ve done test iTunes downloads from two different machines and it’s not updating for those.

    Does anyone know why it would all of the sudden stop recording our download stats correctly? We haven’t changed anything with our feed or setup. The only thing I can think of is that I dragged my feet updating PodPress and WordPress until this evening, trying to fix it. But, even after the updates, iTunes downloads are not reporting when I try from my PC and laptop.

    Any help or advice you could provide would be great. Thanks!

    – Chris

    Website/Podcast URL:

Viewing 15 replies - 1 through 15 (of 19 total)
  • I have tried to subscribe to your podcast with the normal RSS feed URL in iTunes. That was possible and all episodes are available. I have had the same experience as I subscribed to your podcast via the iTunes Store.

    But the iTunes link in your sidebar does not work. One reason is that the iTunes ID (which you can change at the feed/itunes settings page of podPress) is wrong. (Currently it is 1 but your feed id is 342368694)
    The other problem with the link behind the iTunes button is probably a problem of podPress. To solve that temporarily uncheck the checkbox “Use Itunes protcol for URL” in the widget’s settings.

    In conclusion: I have no problems to subscribe to your podcast or to download the latest episodes besides that problem with the iTunes button in your sidebar.
    Furthermore the feed is valid. (That was not the case in almost all other reported cases of not working stats.)
    For what it’s worth I have downloaded the 8th and 9th episode 2-3 times from the feed resp. iTunes.

    But I have no idea why the statistic function seems not to work correctly for feed downloads in your case. So I have some question for you:

    Are you able to tell whether your feed was not valid in the last time?
    Have you changed or redirected the podcast feed URL recently?
    Have you changed something in the robots.txt or the .htaccess files?
    Have you installed one or more new plugins recently? Which one(s)?

    Hi ntm,

    Thanks so much for the quick and thorough response. That’s strange about the feed. I literally checked this out yesterday, before updating PodPress, and it had the correct iTunes ID in there. I fixed it now, though, so it should be working again. Before I posted my original post, I took down the ability to view the download statistics on the main page (I didn’t want to discourage new listeners). I re-enabled that though, in case you wanted to see if the downloads had any impact. I’m still not seeing any update in the feed downloads even from yours recently. Still sitting strong at 14.

    In regards to your questions:

    1) I’m pretty sure our feeds have been functional since we started. They’ve been posting to iTunes for download fine within the default TTL frame. I do use the FeedBurner plugin, though. I disabled it recently for testing and it didn’t seem to make a difference with the stats tracking (not sure if it would anyways).

    2) Since we started, we’ve left everything to do with the feed intact. At least on my end. I have an email out to our site dev. right now to see if anything’s happened behind the scene. I don’t think he’s played with it at all though, since he usually keeps me posted on what’s changing/being tweaked.

    3) No, I haven’t changed anything with them at all. I only found out about them last night while researching, actually.

    4) No new plugins, either. We only really use WordPress Stats, Cystats, Feedburner, and Akismet.

    Could something have gotten corrupted, somehow? I’m open to doing a re-install if that might fix it up. I love PodPress, so I’d really like to keep on utilizing it.

    Thanks again for the help. I really appreciate you taking the time today.

    – Chris

    I’ve been looking through our directory and can’t seem to find any “robots.txt” file. The .htaccess files are there though. Should I have this somewhere?

    Thank you for your answers!

    With robots.txt you can keep most search robots out of your blog. It is no problem if you don’t have such a file. I mentioned it because I have found in my podPress statistics some downloads from a Google bot and these bots are clicking very often on all of the links.
    I have thought that you eventually had banned the bots from your page which could have decreased the number of downloads.

    Ok, I have downloaded episode 8 again and started 2 times the flash player in the post. The counter counted only the the two player hits.

    I will investigate this issue further. But it might be helpful if you could tell me the exact name of the FeedBurner plugin (there are a lot of plugins with “feedburner” in the name). Is it Wp-Feedburner?

    Which “Stat Method” and “Stat Logging” did you use?

    I’m trying reproduce the problem in a test blog. I have installed WP 2.9.1, podPress 8.8.4 (“Stat Method” = Use WP Permalinks / “Stat Logging” = Full and Full+), CyStats and a plugin which is called WP-Stats. But in this combination the counter works for every download type (play/feed/web).

    But I’m not sure if WP-Stats is the WordPress Stats you have mentioned. I have tried a plugin which is called Wp-Feedburner but it was impossible to activate this plugin due to several errors during the activation process.

    Please, tell me the exact names of your plugins so that I can install and test with these plugins.

    I’m relatively sure that it is no general problem of podPress. Because there is at least one other blog (besides my test blog) which does not have this problem with feed stats (but has installed podPress 8.8.4 and WP 2.9.1).

    The Feedburner plugin is titled specifically “FD Feedburner Plugin.” Here’s the homepage to get it easily. WordPress Stats is “ Stats” and is here. My understanding is that it replicates the stat tracking available on the * blogs.

    For “Stat Method” I’m set to “Use WP Permalinks.” Stat Logging is set to “Counts Only.” The test for stats support comes up successful.

    I discovered something interesting tonight though. I tried to download Episode 7 through iTunes and it’s still tracking those stats! Just not 6, 8, or 9. The only difference I could see was that under the “custom fields” section on the edit post page, episode 7 had defaulted to “feature image” where as 8 and 9 were “enclosure” with information on the show title, length, and size. I changed 6, 8, and 9 to match 7 but it didn’t result in any changes.

    The only thing I can think of that changed was we moved from the Suffusion theme to Motion shortly before this started happening. Could it be related to that at all? This is even more perplexing that it’s happening for certain files but not all.

    Okay, I did a little bit more digging and I think I know where this issue is stemming from. Since some shows track and others don’t, I figured that it must be related to the feed. So, I went into FeedBurner ( and used their PodMedic tool.

    The shows that aren’t reporting iTunes downloads are all associated with “podpress_trac” whereas the others are not.

    Here’s are some examples of those that work from the report (copy/pasted exactly):

    Content Item: “The Multiverse – Episode #7: “MMO Divorce””

    * Yay! Media enclosure created for: ~r/multiverse/~5/_a_CKvfIG8k/multiverse07.mp3

    Content Item: “The Multiverse – Episode #5: “Semi-Intelligent Manchild””

    * Yay! Media enclosure created for: ~r/multiverse/~5/2Pr_zbP3VT8/multiverse05.mp3

    Content Item: “The Multiverse – Episode #4: “You Wanna Talk Good””

    * Yay! Media enclosure created for: ~r/multiverse/~5/HAwCXHAPPAE/multiverse04.mp3

    As you can see, they all begin with “~r” I don’t know anything about this, some I’m shooting in the dark.

    Here are the listings of episodes not tracking right:

    Content Item: “The Multiverse – Episode #9: “Guest Starring: Syp””

    * Yay! Media enclosure created for: multiverse/podpress_trac/feed/128/0/multiverse09.mp3

    Content Item: “The Multiverse – Episode #8: “Ringing in the Weekly Show””

    * Yay! Media enclosure created for: multiverse/podpress_trac/feed/116/0/multiverse08.mp3

    Content Item: “The Multiverse – Episode #2: “Skinemax””

    * Yay! Media enclosure created for: multiverse/podpress_trac/feed/37/0/multiverse02.mp3


    I don’t know why they’d be different since I’ve been posting them all the same way through the WordPress dashboard.

    Any ideas on what’s causing it/how to fix it? Thanks again, ntm. You are a total life saver here. We’re trying to get added into a podcast collective at and the low stats are something I know will concern them.

    – Chris

    Some extra info, in case it’s relevant:

    Currently under “Podcast Feed URL” it’s set to our FeedBurner at “”.

    iTunes:New-Feed-Url is set to “Disable.”

    Also, “Enable podTrac Statistics” was turned on under General Settings but that must have been an error since I don’t use it. I just disabled it.

    why not use the plugin called Powerpress and then use a free stat service like podtrack or blubrry?
    Powerpress also imports podpress so there is no need for manual labor

    That’s definitely an option on my mind. I like how podPress is designed and set up, though, so I’d like to keep it if possible. Does podtrac break it down by episode and download type?

    yes they both do

    Hi Chris,

    your feed stats are working, now. I have started the downloads of episode 7, 8 and 9 and their downloads numbers went up 1 point.

    The reason for that change was probably not disabling the option “Enable podTrac Statistics”. But later more …

    … I have to be more precisely. If I click on the RRS Podcast button in your side then reach the Feedburner view one of your news feeds. Only in some of these episodes a “Play now” button is displayed. But if you click on the “View Feed XML” link in the box at the beginning of this view then you will get to different view where some episode have multiple enclosure entries. And if you click on the once which have URLs like yoursiteurl/multiverse/podpress_trac/feed/128/0/episodename.mp3 then the podPress feed download counter counts.

    The other enclosure links are probably added by this PodMedic tool which is in my opinion not necessary here.

    But I tried to download the same episodes from The downloads worked but were not counted.
    The obvious cause for that is that the URLs of the mp3 files are not changed by a pattern like this yoursiteurl/multiverse/podpress_trac/feed/128/0/episodename.mp3. (If you activate the podPress counter then usually podPress masks the URLs of the media files like this. If someone clicks on such a URL podPress counts and redirects to the original URL resp. file. But without these redirection URLs podPress does not count the downloads.
    I will try to find out why that masking does not work for all of your feeds.

    I have to correct myself. In the feed only the media files of the episodes 2, 6, 8 and 9 have not the podPress counter pattern. But now I probably know where I have to look for the cause. ….

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘PodPress stopped tracking iTunes correctly?’ is closed to new replies.