WordPress.org

Support

Support » Plugins and Hacks » podPress » Podpress player doesn't show in post

Podpress player doesn't show in post

  • Podpress player will show in excerpts, but not in the post content. Adding [display_podcast] doesn’t work either. I use Arras Theme, and everything worked fine until I upgraded podpress.

Viewing 15 replies - 16 through 30 (of 33 total)
  • No, everything works perfectly fine, but with 8.8.10.5 and above the player wont show in the single post view. This is the only problem. Actually, I didn’t turn off the html5 feature with beta 4, should I have tried that?

    If you look at my site now, I’m running 8.8.10.4 (so I can have it working in the mean time). When you have new betas, I’ll be glad to test them out, though.

    Plugin Author ntm

    @ntm

    but with 8.8.10.5 and above the player wont show in the single post view.

    Do you mean with “the player” the player and the link elements below the player or only the player?

    Actually, I didn’t turn off the html5 feature with beta 4, should I have tried that?

    If only the player does not appear then try it. But in the other case it will probably make no difference. Although 8.8.10.3-8.8.10.6 have a minor bug which prevents appearance of the HTML5 player in the IE9 browser. The other browser seem to be more tolerant.
    (see the problem of dael3: http://wordpress.org/support/topic/no-player)

    Regards,
    Tim

    I reverted back to 8.10.4 and the player has returned in the posts.

    In the latest DEV version the player did show up in the summaries, though. LEt me know when you think I can upgrade.

    Daniel

    Plugin Author ntm

    @ntm

    franky1029 and Daniel thank you for testing the last beta version. Now, I have tested myself a little bit and I have a further idea on how-to fix this particular problem. I will let you know when the patch is ready.

    Tim

    Plugin Author ntm

    @ntm

    I have made further changes and they are all in the current Development Version (8.8.10.7 beta 5).

    Last time I have tested the modifications only with posts which have an excerpt. That was not intentional but I have noticed my mistake not until your last reports.
    This time I have tested the modifications with post with an excerpt and posts without an excerpt.

    Anyway, it would be great if you could test once more the new beta version.

    Thanks for your patience,
    Tim

    Hi Tim,
    how can I install the development version? Downloaded it, uploaded it to my plugins, but got this error:

    Destination folder already exists. .../html/wp-content/plugins/podpress/
    
    Plugin install failed.

    Thanks

    Plugin Author ntm

    @ntm

    Hi bamboobee,

    it is probably like the message says: the old version of podpress is still installed in your blog and at least the folder of the plugin still exists (…html/wp-content/plugins/podpress/). The cause of the message is maybe that the installation function is not able or not allowed to delete or replace the old files and folders of the plugin.
    (Sometimes scripts like WP are not allowed to do such actions.)

    I would say that you probably need to remove the old files and upload the new ones via FTP.

    Regards,
    Tim

    Hurrah! Beta 5 fixed it! Everything is back to normal! Thank you so much!

    Tim-

    On a related note, when I upgraded my feed is coming back with this error:

    error on line 364 at column 274: EntityRef: expecting ‘;’

    I reverted back to 8.8.10.4 and though our feed is showing up in Google Reader, iTunes hasn’t updated all week.

    Suggestions?

    Thanks!

    DR

    I also checked my feed in iTunes to try to validate, and suddenly I’m getting this:

    line 282, column 128: XML parsing error: <unknown>:282:128: not well-formed (invalid token) [help]

    This might be what’s not allowing iTunes to update with the most recent podcasts.

    DR

    Okay-
    Updated to latest DEV version. The Feed is validating.

    Also- the player is there, but it disappears when I check Use HTML Tags. For now, I have to keep that unchecked. I quite liked that feature.

    That seems to be the only problem right now.

    DR

    Plugin Author ntm

    @ntm

    @franky1029 and Daniel: These basically good news. I’m relieved to hear that nearly problems are resolved.

    Thanks to you both for your patience and for testing all those beta version!

    @daniel:

    Also- the player is there, but it disappears when I check Use HTML Tags.

    Does only the player or the player and the links below the player disappear when use activate the “Use HTML5 Tags” option?
    Which browser do you use? (Safari?, Chrome?, IE9?)

    Most web browser have something called error console. That error console (might have in some browsers a different name) shows you all HTML and Javascript errors of a web page.
    Please, activate the HTML5 tags, open one of the blog posts with a podcast episode in the browser, open the error console clear its existing content and reload the blog page.
    Which errors do you see in the error console?

    (If you would leave that HTML5 option active or activate it for an hour or two I could see myself what the problem is. I’m the next hours in front a computer with an Internet connection and ready to do that.)

    Tim

    I too upgraded to 8.8.10.6 and lost my player in posts. When will the upgrade be released?

    Thanks so much!

    Plugin Author ntm

    @ntm

    I will release 8.8.10.7 at this weekend (Saturday or Sunday).

    Hey Tim-

    Quick question, probably should start a new thread. I’d like to my listeners to be able to subscribe to the individual category itunes feeds. The Widget only has RSS feeds for categories.

    Is there anything already in Podpress that would allow me to do this. I was looking at Podtrac Player because it’s a little snazzier, but Podtrac asks that you add the iTunes ID into the RSS. I don’t think I can edit the RSS in WP without messing everything up.

    What would you recommend? Is there a podcast player out there that will do this? Am I missing something in Podpress?

    Dan

Viewing 15 replies - 16 through 30 (of 33 total)
  • The topic ‘Podpress player doesn't show in post’ is closed to new replies.
Skip to toolbar