WordPress.org

Support

Support » Plugins and Hacks » podpress not working in subdirectory

podpress not working in subdirectory

  • Hi,

    I can get podpress to work if it’s installed in the root directory…

    but for blog installed in a subdirectory it won’t work.

    In the admin area where you configure podpress…

    Feed/iTune setting…the iTunes Preview is blank… it won’t pull the graphic or give description and blog title.

    Player Settings… the podpress colour image map isn’t showing and mouse over color selector won’t work.

    Writing a Post
    The Podcast section doesn’t drop down the options when you click the “Add Media File” and “Show”

    It appears that the java script isn’t being called/recognized in the subdirectory.

    I’ve uninstalled and re-installed podpress… even deleted the blog and started again with a new database and still get this problem…

    Any ideas on why this is happening in a blog installed in a subdirectory?

    Thanks
    Ann

Viewing 9 replies - 1 through 9 (of 9 total)
  • I had several test installs in subdirs and it always worked.

    Had anybody else experiencing this problem?

    Obviously something isn’t working correctly and the Podpress support is outdated.

    Is there something that needs to be configured on .htaccess?

    Am I installing it wrong on the subdirectory or what?

    If you try the URL for the podpress image
    http://www.drarndt.com/clients/wp-content/plugins/podpress/images/powered_by_podpress.jpg

    it takes you back to the main site… although the image is indeed in their.

    When I install it podpress in the main root… no problem
    http://www.drarndt.com/wp-content/plugins/podpress/images/powered_by_podpress.jpg

    So there has to be something not right.

    Thanks
    Ann

    What is “clients”? It seems you have a catgeory or Page AND a subdomain with the same name…

    PodPress can work fine in a subdirectory.

    This appears to be the htaccess file of your top-directory, getting in the way. This probably means that your top-level site (I assume it’s a WordPress at your top level?), has a Category or a Page with the same name as your sub-directory, “Clients”.

    re-name your sub-directory to aoifxubharzig and try it.

    be sure to never make a Category or Page at the top level, that has the same slug (URL) as a folder in your FTP

    Hi

    Clients is the subdirectory…

    I double checked and no category or page is named clients

    Yes, we installed wordpress in the main root and now he want a separate area for his clients.

    I’ll try installing it in a different sub-directory and see what happens.

    Thanks
    Ann

    Hi

    Thanks… installing it in a different subdirectory worked…

    Must have created a client category at one time although it’s no longer there.

    Ann

    Or a Page? And even if you changed the title of that Page… the slug remains what has been given the first time.

    Thanks… just want to make sure we don’t break it 🙂

    since the subdirectory is coaching-corner

    Don’t name a page, category and/or slug coaching-corner

    correct?

    Ann

    correct, and theoretically you can name a Page or Category that, if you change the slug to something different

    the slug’s the key to the permalink rewrites

    I believe

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘podpress not working in subdirectory’ is closed to new replies.