[resolved] Podpress media player "File not found" (9 posts)

  1. LowAims
    Posted 3 years ago #

    Hi all,

    I am very new to WordPress, and have just started using the Podpress plugin to upload podcast episodes.
    Currently, I am able to select the podcast episode to upload with a post from the drop down menu, as the "Absolute path of the media files directory" has been properly defined. (/home/lowaims/public_html/wp-content/uploads) The plugin also auto-detects the file size and duration of the episode correctly.

    Once I publish the post, however, the Podpress player shows "file not found" and the download link shows the "page not found" error.

    Could anyone show me where I might be going wrong? Or direct me to another thread that solves this issue? (My extensive searching has yielded nothing helpful so far.)

    The website is http://www.lowaims.com, if that helps.

    Thanks in advance!

  2. ntm
    Posted 3 years ago #

    Maybe it is a problem related to your current Permalink setting and a name of a real folder.
    The Permalink technique transforms URL like http://www.example.com/?p=123 into nicer URLs which look like folders e.g. http://www.example.com/my_post_with_the_id_123

    Sometimes one can experience funny effects like in cases when category or sub category names are equal to names of real, existing folders.
    For example, if you try to open the folder of your podcast episodes:
    then you will be forwarded to

    I guess if you open an URL with a file name at the end it this redirection would happen also. But there no media files at http://lowaims.com/category/episodes/ and that is probably why you end up with a 404 page.

    Try to set the Permalink scheme back to the default scheme. Does the effect disappear when you do that?

  3. LowAims
    Posted 3 years ago #

    Thanks again,

    I set the permalink scheme back to the WP default, and attempted to reload the episode. Still received the "File not found" error on the media player.
    I did notice however that now when I click the "download" link I now receive a 404 error from Hostgator, rather than wordpress. I get this same error if I go to the "epdisodes" category. I think this may be a lead.

    I currently have no access to my FTP since I'm at work, but I'll tonight attempt to rename the directory to something different (Perhaps "shows" instead of "episodes") and see if that helps?

    I will keep you posted.

  4. LowAims
    Posted 3 years ago #

    In an attempt to stop this issue, I renamed the category "Episodes" to "Shows" as well as the page that redirected to this category. I am still receiving the 404 Error from Hostgator and the "File not found" error.

    This is all very strange, can't seem to make any sense of why this would be happening.

  5. LowAims
    Posted 3 years ago #

    As embarrassing is to day it, I think I may have fixed this.

    All it took was removing the /public_html/ from the Podpress media files directory, and everything suddenly worked!

    Thanks again, @ntm! I told you I was very new to this!!

  6. ntm
    Posted 3 years ago #

    It is great that you have found the solution to this problem!

    I never would have guessed that a part of the "Absolute path of the media files directory (optional)" could be wrong.
    There is a question mark next to the name of the option on the General Settings page of podPress. A click on this question mark will display a little documentation to this option. This text contains also an example of what the path of the upload folder might be. Does this example contain /public_html/?

  7. LowAims
    Posted 3 years ago #


    Yeah, I thought it was pretty strange, too. Complete chance that I found it!

    The suggested folder shows "/home/lowaims/public_html/wp-content/uploads"
    This is what I originally had as the absolute path, and with this it would give me the drop-down selector in the "add media file" field, but I was receiving the "file not found" error.

    Interestingly enough, although the files are playing properly on the site, Podpress now shows "This directory is not valid or not accessible." underneath the absolute path field. I also do not have access to the drop-down menu when selecting media. I have to add the path manually!

    Any suggestions as to why this might be happening? Although it's a minor issue in the scope of things, it would make it a lot easier to upload my shows.


  8. ntm
    Posted 3 years ago #

    Podpress now shows "This directory is not valid or not accessible."

    Well, podPress controls whether the given folder exists and shows this message if it does not exist.

    Is /home/lowaims/public_html/wp-content/uploads really not the correct path? Is the folder above /wp-content really /lowaims?

    It seems not right to cut one sub folder name out of a full path.

    Have you tried to rename the /uploads/episodes?

  9. LowAims
    Posted 3 years ago #

    The correct path is "http://lowaims.com/public_html/wp-content/uploads/episodes" (at least according to my FTP software.)
    However it only works with the "public_html" taken out.

    Haven't done that yet - to be honest I'm just glad it's working now.

Topic Closed

This topic has been closed to new replies.

About this Topic