Support » Plugin: podPress » podPress: 'invalid feed template', but no idea why

  • Resolved indextwo

    (@indextwo)


    A friend had a WordPress 2.x website developed by someone else a while ago, and they had done some kind of manual hack to force the podpress feed to be /?feed=podcastfeed rather than just podcast. This was so it didn’t cause a conflict with the page /podcast, which had already been created, apparently. This worked fine.

    They have since upgraded WordPress and all of the plugins, and now the hack (which was manually added again) no longer works. I took a look at it, and couldn’t quite wrap my head around it. I ended up re-uploading a completely fresh install of podpress, effectively removing the hack, and still no joy. I manually updated the feed URL in General Feed Settings, still no joy. I spent half an hour trailing through the SQL, and every reference I could find to the podpress feed URL states that it is, in fact, set to /?feed=podcastfeed – but it only ever gives an error. However, the default /?feed=podcast works just fine, even though there doesn’t seem to be any reference to it anywhere. Take a look:

    http://residerealestate.com/?feed=podcast (works)

    http://residerealestate.com/?feed=podcastfeed (doesn’t work)

    The issue is that a lot of people have been subscribed to /?feed=podcastfeed for a while now, and that’s how the iTunes feed is set up, and now those same people are going to be missing out.

    Can anyone solve this one? Because I’m clean out of ideas.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author ntm

    (@ntm)

    You will need change one line of code in the podpress.php file:

    podpress.php line 243 of podPress v8.8.6.3:
    old:

    add_feed('podcast', 'podPress_do_feed_podcast');

    new:

    add_feed('podcastfeed', 'podPress_do_feed_podcast');

    Save your Permalink Setting afterwards, again.

    (The Podcast Feed URL in Feed/iTunes Settings is more important for the iTunes:New-Feed-Url tag resp. function.)

    Regards,
    Tim

    Plugin Author ntm

    (@ntm)

    I meant to write line 234.

    Plugin Author ntm

    (@ntm)

    If your are using the podPress – Feed Buttons Widget then you may want to change line 540 in the file podpress_functions.php according to the custom name of the podcast feed.
    old:

    echo '  <li><a href="'.get_feed_link('podcast').'" title="'.__('Subscribe to the Podcast RSS Feed with any other podcatcher', 'podpress').'"><img src="'.podPress_url().'images/button_rss_podcast.png" class="podpress_feed_buttons" alt="'.__('Subscribe to the Podcast RSS Feed', 'podpress').'" /></a></li>'."\n";

    new:

    echo '  <li><a href="'.get_feed_link('podcastfeed').'" title="'.__('Subscribe to the Podcast RSS Feed with any other podcatcher', 'podpress').'"><img src="'.podPress_url().'images/button_rss_podcast.png" class="podpress_feed_buttons" alt="'.__('Subscribe to the Podcast RSS Feed', 'podpress').'" /></a></li>'."\n";

    Plugin Author ntm

    (@ntm)

    … and the same in line 577 in podpress_functions.php

    Thankyou! Changing the ‘podPress_do_feed_podcast’ action worked a treat. *wipes brow*

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘podPress: 'invalid feed template', but no idea why’ is closed to new replies.