Support » Plugins » Podpress file path problem

  • Resolved bravenewniche


    I thought I’ve entered the paths correctly in the PodPress settings and in the Location field of the post itself, but I get this as the download URL:

    [audio src="http://mydomain.comhttp//" /]

    In the General Settings, URL of media directory, I have:

    and in the Location field for the post itself I have:


    I’ve tried just entering the mp3 file name, but it automatically reverts back to this path…

    Any ideas? Couldn’t find anything in the podpress documentation, and it seems like I’m doing what the popup help says within podpress…

Viewing 4 replies - 1 through 4 (of 4 total)
  • I changed the WordPress URL in the WordPress settings, and added http://www., which changed that first to, so clearly podpress is using the WordPress settings to inject the base URL for the site – so why is it asking for a full URI in the podpress settings???

    Going to try changing podpress general settings to give only the path from root to the podcast file folder…

    Well, that’s the answer to that question.

    1. Podpress uses the URL in your WordPress settings
    2. In podpress General Settings, enter the URI as /root/to/files/

    Now, presumably we only need to add the file name in the actual post, under Location….

    Tried that, but it keeps reverting to


    when I re-save the post.

    Ok, so now I go back and completely clear the URI in General Settings for Podpress…. It works!

    So to recap what actually worked for me:

    1. Podpress uses the URL in your WordPress settings
    2. In podpress General Settings, leave the URI blank
    3. In the individual post, under Location, enter /path/to/podcastfiles/mysounds.mp3

    Counter-intuitive to say the least, but it’s working for me.

    Ok, sounds like you’re good to go then. Enjoy!]

    For me, under the Write Post > Podpress area > Location field, podpress gives me a nice dropdown menu that shows me all the files in the folder I specified in the settings.

    So it’s just a drop-down, point and click to choose the file, for me, with podpress.

    After saving that post the second time, I’m now seeing the drop down menu, Dgold. I wonder if, because it was my first MP3 uploaded, that the system hadn’t started cataloguing them…??

    However, what I see in the drop down menu is


    and if I go back to General Settings in PodPress and enter


    I get the same problem again with having two paths in the final URL in the post, and therefore the file won’t load… weird


    So, a few days later and we uploaded a bunch more MP3s – all of a sudden, they’re showing up in the drop down menu in Posts, with only the file name and no path whatsoever… Just as Dgold said above.

    Had to go back into General Settings, enter

    and everything’s working fine.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Podpress file path problem’ is closed to new replies.