Support » Plugins and Hacks » PodPress disables image posting

PodPress disables image posting

  • Hello.

    I have been a WP user for 2+ years and this board has always been a great resource for the problems I encounter.

    This time, however, the problem I am facing does not seem to be posted anywhere.

    The problem involves WP (v2.1.2) and the PodPress Plug-in (v8.5).

    When I enable the Podpress plug-in, my ability to insert an image into a post is disabled.

    When the PodPress Plug-in is enabled, the options I get in Manage > Post > Browse (Uploads) are as such:

    Link to:
    – File
    – Page
    – None
    Curiously the thumbnails of the images do not render, instead they are replaced by text of the file name.

    When PodPress is disabled, I get the usual options in Manage > Post > Browse (Uploads)

    – Thumbnail
    – Full size
    – Title

    Link to:
    – File
    – Page
    – None
    The thumbnails of the images do render. And I am able to send the selected image to the Post (Visual Editor) text field.

    Also when hitting the SHOW button in the Podcasting section of a Manage > Posts page, the following error is displayed..

    parse_url(/wp-content/plugins/podpress/podpress_backend.php?action=showID3Contents&filename=http://www.rockandrollreport.com/wp-content/uploads/podcast/071016_frank_mills.mp3&keynum=0) [function.parse-url]: Unable to parse url in /home/markrock/public_html/wp-content/plugins/podpress/podpress.php on line 151

    Thanks for your attention.

Viewing 15 replies - 1 through 15 (of 15 total)
  • I have the same problem using pod press. I am not a coder and cannot help. Just letting you are not alone. I have to deactivate podpress to post pictures.
    Mark McGillveray

    Hi Mark,

    We are definitely not alone. I’m also deactivating podpress to post pictures…


    I have the same problem. This is supposed to be fixed in version 8.7 according to the MightySeek forums. Not sure if it has been released yet but this is a problem that has festered for awhile.

    I still have the problem with version 8.8. Whenever I upload images, I have to first disable PodPress and then reactivate it when I’m done.

    I’ve posted about this issue on the PodPress forum (at MightySeek.com) a few times in the past week. The moderator keeps saying the issue has been resolved. It’s certainly not resolved in my case — and I’m using the most current version of everything (PodPress 8.8 and WP 2.3.2). Actually the PodPress forum moderator offers a staging system where you can try it out. I did try it and had the same problem. Upload an image and there’s no thumbnail option if PodPress is activated. Deactivate PodPress and upload the same image and the thumbnail option is there.

    People often suggest that if you’re having an issue with thumbnails, it may be because the GD library needs to be enabled or updated. First, however, I’d try temporarily deactivating PodPress and if that solves the image problem, at least you’ll know you that you don’t have to chase down non-existent issues with the GD library.

    Moderator Samuel Wood (Otto)


    WordPress.org Tech Dude

    It’s a podpress bug, and I think I just found it by looking carefully through the podpress code.

    If you look at podpress.php (version 8.8 of the plugin), on line 423 you’ll find this code:

    function podPress_wp_get_attachment_metadata($data, $id='') {
    	if(is_feed()) {
    		return '';
    	} else {
    		return $file;

    That code is broken. “$file” is undefined at that point. It should be returning $data instead. So fix it like so:

    function podPress_wp_get_attachment_metadata($data, $id='') {
    	if(is_feed()) {
    		return '';
    	} else {
    		return $data;

    And I think that will solve your problem.

    Excellent. That certainly seems to give us back the thumbnail functionality. Thank you very much.


    Good catch! I will let seek3r know, I have also setup my install with that change and it works perfect.

    more info here :

    THANKS!!! I am new to wordpress. I was pulling my hair out looking for a plugin to automate creation and insertion of thumbnails into posts because I didn’t think WP did this “out of the box”.

    That little chage fixed it all. Oh – And for those doing this type of image insert. Check out the following two small plugins to go with that feature

    Add Lightbox 0.2
    Lightbox 2 2.5.0

    Both those work together and give you that slick lightbox effect without you needing to do anything other than what you normally do to upload your pictures.

    I’m sorry, but I must be missing a step. Just installed podpress, because I have the problem from above – no thumbnail option in 2.3.2 image upload.

    However the podpress.php fix does not work for me. I still see no thumbnail option and my podpress area in post editor displays ‘End of podPress. File Uploading support is not part of podPress’

    ‘End of podPress. File Uploading support is not part of podPress’

    that is correct. You use the standard WP upload dialog for all file uploads.

    I just tried the code fix and it’s working properly for me.

    try phpinfo and see if it tells you GD library is installed. there should be a gd section in your phpinfo report, and it should report GD support enabled. Google phpinfo if you are confused.

    thank you Otto42 – you have solved a problem that has been dogging me for weeks — each time I uploaded a post I had to de-active podpress and then remember to re-activate it at the end of posting. I just love this whole system of wordpress – internet at its best … thank you again


    Otto42, thanks for the fix. Query though. Does this apply to old images that were uploaded before or just new ones?

    I can do thumbnails of new uploads but am having difficulty doing that with old uploads.

    Would this fix also fix a problem with podpress not showing the preview jpg with flash videos? Several of us have asked the author of the plug-in in his forums, and he acknowledges there’s a problem, but doesn’t seem too interested in fixing it. Given that FLASH (flv) is ubiquitous, this is a pretty serious error. I have deactivated PodPress and gone to another plugin because I got tired of waiting for the author to fix the problem. You can see the discussion on his forum at: http://www.mightyseek.com/forum/showthread.php?p=4102#post4102

    This really renders a very nice plug-in unusable.

    wow. that one edit fixed everything.

    thanks otto42!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘PodPress disables image posting’ is closed to new replies.