Support » Fixing WordPress » Podpress can't find my podcast file

  • I have another question and since I’m a newbie I’m sure its a pretty stupid one (again). I am trying to upload my first podcast but the podcast player provided by podpress won’t play my file. It says “File Not Found”. I know I entered the correct file in the file location section because I copied and pasted it into my browser and it works fine ( Podpress can autodetect the file size and duration just fine. What am I doing wrong? Any help is very much appreciated!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The player that you are currently using (the podango player) seems plays the file without problems. And if this player is able to play the file, then the 1 Pixel Out player should not have a problem.
    Furthermore I have created a draft post and added the episode to my post. It was possible to play the episode in the post preview with both players.
    The fact that podPress can auto-detect file size and duration is a further good sign. So for me looks all fine now. Maybe it was only temporarily server problem or maybe there was a typo in the link.

    Have you tried the 1 Pixel Out player? Did the 1 Pixel Out player not find the file?

    Well I actually had to delete WordPress and reinstall it and it worked. Now I’m having another problem with the feed for my podcast. It validated fine last night and again today, but once I changed my theme the feed validator says:

    “Server returned HTTP Error 404: Not Found”

    I posted a message a few days ago and you mentioned that I needed to upload the podcast file before the feed would validate. I have one uploaded but its not validating so I am totally out of ideas. Is there something I need to do to make the feed work with my new theme? Are there only certain themes that will allow the feed to work? Thanks so much for your help!


    This is my first time using podPress, but I’m having a similar issue.

    I have podPress fully upgraded but when I add my MP3 the player shows up “File Not Found.” Auto detect does not work.

    I know it’s the right URL because the download link works perfect.

    Does anyone have any suggestions?

    “File Not Found.” can have multiple causes. But basically something is wrong with the URL of the media file.
    One thing which is often the cause is a not complete statistic feature/permalink configuration. Does the problem occurs while the statistic feature of podPress is deactivated?
    (If not then read the thread which is linked above carefully.)

    “Auto detect does not work.” – There are also multiple explanations for this message. But you can get a detailed response when you try to retrieve the ID3-Tags. For instance if there is something wrong with URL you have entered as the location you will get a clear error message if you use this ID3 function.
    Please, post the error message here.
    Is the content of the file size field after the auto detection the word UNKNOWN or something else? Please, copy the content of this field and post it here.
    That the Auto Detection of the file size, the duration or the ID3 tag retrieval not works is often a sign for a wrong URL. But there are maybe other reasons. Are your media files located on the same domain as your blog?


    After spending countless hours on this with no success we tried downgrading the quality of the MP3.

    We originally saved it at 320kbps which was about 80mb. We downgraded it to 192kbps which was 45mb.

    It worked.

    I’m not sure if it was the bitrate or file size, but downgrading worked.

    Thanks for the reply! I never would have guessed that a high bitrate is responsible for this error message. (Although I know there was an issue with the bitrate and this mp3 player in the past.)

    podPress uses two MP3 players: the Podango player has probably no further support but the 1PixelOut player which is also know as the WP Audio Player has still technical support. It is probably a good idea to ask the developer of this player for help or at least some information about such a limitation.
    The file size is most likely not the problem because I definitely know of podcast episodes which are bigger than 150 MB and which are playable with at least the 1PixelOut player.

    Which player do you use?

    I tried both 1PixelOut and Podango as well as another streaming audio option to test the MP3. All had the same result.

    Downloading the MP3 or playing it in the browser worked fine.



    Hello, I’m having the same issue in which the .mp3 preview plays without statistics, but won’t play with statistics.

    I have chosen the correct name and day permalink structure

    I have also noticed that there is no .htaccess file in the root of the wordpress folder.

    Please, how do I create an .htaccess file for the root so that the preview will play with statistics checked?




    Please, how do I create an .htaccess file for the root so that the preview will play with statistics checked?

    It depends on your webserver and the method you are using to access it. Assuming Apache via FTP:
    1. Create a blank file with a texteditor (like notepad on windows) and save it as htaccess.txt
    2. upload it to the root wordpress folder
    3. change the filename to .htaccess
    4. temporarily change the file permissions to 666 (world readable, world writable)
    5. set the permalink structure in wordpress admin console and save it.
    6. verify the contents of the file and then change the permissions back to 644 or whatever your narmal permissions are

    (using ssh just do ‘touch .htaccess’ and ‘chmod 666 .htaccess’)

    More details on using permalinks here:
    (Also remember that Google is your friend – try ‘.htaccess tutorial’)

    Hope this helps.
    Ray Mercer



    Hi Ray, thanks for taking the time to respond. Its a Plesk server, does this mean anything? I actually attempted to upload an htaccess from a colleagues site who successfully runs podpress and statistics. Not suprisingly, it didn’t work 🙂 This is what the current htaccess says:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

    As a complete novice at htaccess, can you please tell me where in this code to change the file permissions to 666?

    Also, does it matter how I upload the htaccess via FTP? I read somewhere that htaccess must be uploaded as ACII, not binary? Is that true? thanks again




    Its a Plesk server, does this mean anything?

    Plesk is probably your web-interface – I would assume you are running Apache underneath.

    I actually attempted to upload an htaccess from a colleagues site who successfully runs podpress and statistics.

    WordPress will write the contents of this file for you but you have to make sure the filename exists and that it is writable. So its fine that you uploaded the file from your friend’s server. You just need to make sure that it is named .htaccess (note that the period is required there) and that the file permissions allow writing by the PHP script.

    What FTP client did you use to upload your friend’s file? Filezilla? If you are using a webinterface from your hosting service can you view/change the filename? Whatever client you are using, check and make sure it is named .htaccess – Then find an option like “file permissions” and set it to 666 or 777. (note that this makes the file writable by anyone so be sure to set it back later)

    Now log in to your WordPress admin console and navigate to settings | permalinks. Choose a non-default setting – like “numeric” and then click “Save Changes” If the file is in the correct location and the permissions are correct WordPress will show you this message “Permalink structure updated.” That means that the .htaccess file contents has been written and should work fine. If you see an error message please report that message here.

    Then go back and change your file permssions on the .htaccess file to 644 or whatever the other files are set to on your server so that a hacker doesn’t try to use it to compromise your site.

    I don’t mind helping out but this stuff is pretty basic and is all included in the WordPress documentation. You should learn about files and file permissions if you plan to use a self-hosted WordPress install.




    Oh yes, to answer your question about upload types. You should upload the file as ASCII but most FTP clients will auto-detect this for you anyway.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Podpress can't find my podcast file’ is closed to new replies.